Click or drag to resize

SubDPatchStyle Enumeration

SubD::PatchStyle identifies the style of patch used to fill holes.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum SubDPatchStyle
Members
  Member nameValueDescription
Unset0 Not a valid style. This encourages developers to thoughtfully select a patch style and can be used to indicate a UI control is not initialized.
Automatic1 Automatically choose a patch style that will generally create a good looking result. If a hole boundary is not convex, it is triangulated. Otherwise: If a hole has 3 edges, a single triangle face is used. If a hole has 4 edges, a single quad face is used. If a hole has 5 or more edges and an odd number of edges, a triangle fan is used. If a hole has 6 or more edges and an even number of edges, a quad fan is used.
SingleFace2 A single face is used under all conditions.
TriangleFan3 A triangle fan used under all conditions. The center of the fan is the average of the hole boundary vertex control net points.
QuadOrTriangleFan4 If the hole boundary has an even number of edges, a quad fan is used. Otherwise a triangle fan is used. The center of the fan is the average of the hole boundary vertex control net points.
Triangulated5 The hole boundary is triangluated. Typically this style is selected when a boundary not convex and the other styles produce faces with overlapping regions.
See Also