Click or drag to resize

Torus Structure

Represents the value of a plane and two radii in a torus that is oriented in three-dimensional space.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Torus : IEpsilonComparable<Torus>

The Torus type exposes the following members.

Constructors
  NameDescription
Public methodCode exampleTorus
Initializes a new Torus from base pane and two radii.
Top
Properties
  NameDescription
Public propertyIsValid
Gets a value indicating whether this torus is valid.
Public propertyMajorRadius
Gets or sets the radius of the circle that lies at the heart of the torus.
Public propertyMinorRadius
Gets or sets the radius of the torus section.
Public propertyPlane
Gets or sets the plane for the torus large circle.
Public propertyStatic memberUnset
Gets an invalid Torus.
Top
Methods
  NameDescription
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodToBrep
Converts this torus to a Brep. This is synonymous with calling CreateFromTorus(Torus).
Public methodToNurbsSurface
Converts this torus to its NURBS surface representation. This is synonymous with calling CreateFromTorus(Torus).
Public methodCode exampleToRevSurface
Converts this torus to a surface of revolution representation. This is synonymous with calling CreateFromTorus(Torus).
Top
See Also