Click or drag to resize

Rhino.Geometry Namespace

The Geometry namespace contains geometric types used in Rhino.

Examples are lines, curves, meshes and boundary representations.

Classes
  ClassDescription
Public classAngularDimension
Represents a dimension of an entity that can be measured with an angle.
Public classAnnotationBase
Provides a common base class to all annotation geometry.

This class refers to the geometric element that is independent from the document.

Public classArcCurve
Represent arcs and circles.

ArcCurve.IsCircle returns true if the curve is a complete circle.

Public classAreaMassProperties
Contains static initialization methods and allows access to the computed metrics of area, area centroid and area moments in closed planar curves, in meshes, in surfaces, in hatches and in boundary representations.
Public classArrowhead
Arrowhead used by annotation
Public classBezierCurve
Represents a Bezier curve.

Note: as an exception, the bezier curve is not derived from Curve.

Public classBezierSurface
Represents a Bezier surface.
Public classBrep
/// Boundary Representation. A surface or polysurface along with trim curve information.
Public classBrepEdge
Represents a single edge curve in a Brep object.
Public classBrepEdgeFilletDistance
Fillet distances along a BrepEdge
Public classBrepFace
Provides strongly-typed access to brep faces.

A Brep face is composed of one surface and trimming curves.

Public classBrepLoop
Represent a single loop in a Brep object. A loop is composed of a list of trim curves.
Public classBrepRegion
Represents a brep topological region that has sides.
Public classBrepRegionFaceSide
Represents a side of a BrepRegion entity.
Public classBrepTrim
Brep trim information is stored in BrepTrim classes. Brep.Trims is an array of all the trims in the brep. A BrepTrim is derived from CurveProxy so the trim can supply easy to use evaluation tools via the Curve virtual member functions. Note well that the domains and orientations of the curve m_C2[trim.m_c2i] and the trim as a curve may not agree.
Public classBrepVertex
Brep vertex information
Public classCentermark
Represents a center mark dimension.
Public classClippingPlaneSurface
Represents a planar surface that is used as clipping plane in viewports. A clipping plane object maintains a list of viewports that it clips against.
Public classCurve
Represents a base class that is common to most RhinoCommon curve types.

A curve represents an entity that can be all visited by providing a single parameter, usually called t.

Public classCurveBooleanRegions
Represents the results of a Curve.CreateBooleanRegions calculation.
Public classCurveProxy
Represent curve geometry. Usually this is part of another piece of geometry that can be represented as a "proxy".
Public classDetailView
Represents a view of the model placed on a page layout.
Public classDevelopableSrf
Helpers for developable surface functions
Public classDimension
Base class for dimensions
Public classExtrusion
Represents an extrusion, or objects such as beams or linearly extruded elements, that can be represented by profile curves and two miter planes at the extremes.
Public classGeometryBase
Provides a common base for most geometric classes. This class is abstract.
Public classHatch
Represents a hatch in planar boundary loop or loops. This is a 2d entity with a plane defining a local coordinate system. The loops, patterns, angles, etc are all in this local coordinate system. The Hatch object manages the plane and loop array Fill definitions are in the HatchPattern or class derived from HatchPattern Hatch has an index to get the pattern definition from the pattern table.
Public classHermiteSurface
Create an ON_NurbsSurface satisfying Hermite interpolation conditions at a grid of points.
Public classHiddenLineDrawing
Represents a hidden line drawing object. A hidden line drawing consists of curves generated from source objects. The curves correspond to edges, and silhouettes of source objects and intersections with cutting planes.
Public classHiddenLineDrawingObject
Represents an object added to a HiddenLineDrawing
Public classHiddenLineDrawingObjectCurve
Curves generated from source objects which correspond to edges, and silhouettes of source objects and intersections with cutting planes. A HiddenLineDrawingObjectCurve is partitioned into hidden and visible segments called HiddenLineDrawingSegment
Public classHiddenLineDrawingParameters
Input used for computing a hidden line drawing
Public classHiddenLineDrawingPoint
Points generated from source objects which correspond to point and point cloud source objects.
Public classHiddenLineDrawingSegment
The results of HiddenLineDrawing calculation are a collection of segments. A segment is a sub-curve of a HiddenLineDrawingObjectCurve.
Public classInstanceDefinitionGeometry
Represents a block definition in a File3dm. This is the same as Rhino.DocObjects.InstanceDefinition, but not associated with a RhinoDoc.
Public classInstanceReferenceGeometry
Represents a reference to the geometry in a block definition.
Public classInterpolator
Exposes a set of standard numeric interpolation algorithms.
Public classInvalidDimensionStyleIdException
General exception that can be thrown by annotations
Public classLeader
Leader geometry class
Public classLengthMassProperties
Contains static initialization methods and allows access to the computed metrics of length, length centroid, and length moments in curves.
Public classLight
Represents a light that shines in the modeling space.
Public classLinearDimension
Represents a linear dimension
Public classLineCurve
Represents a linear curve.
Public classMatrix
Represents an arbitrarily sized matrix of double-precision floating point numbers. If you are working with a 4x4 matrix, then you may want to use the Transform class instead.
Public classMesh
Represents a geometry type that is defined by vertices and faces.

This is often called a face-vertex mesh.

Public classMeshBooleanOptions
Contains a set of data to pass to boolean options.
Public classMeshDisplacementInfo
Contains mesh displacement information.
Public classMeshExtruder
Extrudes a mesh and provides preview
Public classMeshingParameters
Represents settings used for creating a mesh representation of a brep or surface.
Public classMeshNgon
Represents a mesh ngon.

When retrieved from the Ngon property of a mesh, this contains faces that have edge valence strictly higher than 4.

When retrieving Ngons from GetNgonAndFacesEnumerable, this might contain also triangles and quads.

Public classMeshPart
Represents a portion of a mesh for partitioning
Public classMeshPoint
Represents a point that is found on a mesh.
Public classMeshUnsafeLock
Permits access to the underlying mesh raw data structures in an unsafe way.
Public classMeshUnwrapper
Unwraps meshes and stores the result in their texture coordinates
Public classMorphControl
Represents a geometry that is able to control the morphing behavior of some other geometry.
Public classNurbsCurve
Represents a Non Uniform Rational B-Splines (NURBS) curve.
Public classNurbsSurface
Represents a Non Uniform Rational B-Splines (NURBS) surface.
Public classOrdinateDimension
Represents an ordinate dimension
Public classParticle
Represents a simple particle.

This base class only defines position and display properties (size, color, bitmap id). You will most likely create a class that derives from this particle class to perform some sort of physical simulation (movement over time or frames).

Public classParticleSystem
Public classPlaneSurface
Represents a plane surface.
Public classPoint
Represents a geometric point.

This is fundamentally a class that derives from GeometryBase and contains a single Point3d location.

Public classPoint3dGrid
Represents a rectangular grid of 3D points.
Public classPointCloud
Represents a collection of coordinates with optional normal vectors and colors.
Public classPointCloudItem
Represents a single item in a point cloud. A PointCloud item always has a location, but it has an optional normal vector and color.
Public classPointCloudUnsafeLock
Permits access to the underlying PointCloud raw data structures in an unsafe way.
Public classPolyCurve
Represents a curve that is the result of joining several (possibly different) types of curves.
Public classPolyline
Represents an ordered set of points connected by linear segments.

Polylines are closed if start and end points coincide.

Public classPolylineCurve
Represents the geometry of a set of linked line segments.

This is fundamentally a class that derives from Curve and internally contains a Polyline.

Public classQuadRemeshParameters
Parameters for QuadRemesh method
Public classRadialDimension
Represents a dimension of a circular entity that can be measured with radius or diameter.
Public classReduceMeshParameters
Parameters for Reduce method
Public classRevSurface
Represents a surface of revolution.

Revolutions can be incomplete (they can form arcs).

Public classRTree
Represents a spatial search structure based on implementations of the R-tree algorithm by Toni Gutman.
Public classRTreeEventArgs
Represents event data that is passed when an item that meets certain criteria is found and the passed RTree event is raised.
Public classShrinkWrapParameters
Parameters for ShrinkWrap method
Public classShutLiningCurveInfo
Public classSilhouette
Information about silhouette curves that are generated from geometry (surfaces, brep faces, meshes)
Public classSpaceMorph
Represents a spacial, Euclidean morph.
Public classSquisher
class used to wrap Squish functions
Public classSquishParameters
Parameters used by the 'Squish' command flattening algorithm
Public classSubD
Subdivision surface
Public classSubDComponent
A part of SubD geometry. Common base class for vertices, faces, and edges
Public classSubDCreationOptions
Options used for creating a SubD
Public classSubDDisplayParameters
A collection of parameters that are passed to functions that calculate a various representations of SubD objects.
Public classSubDEdge
Single edge of a SubD
Public classSubDFace
Single face of a SubD
Public classSubDSurfaceInterpolator
Interpolate some or all of the vertices limit surface positions in a SubD to specified locations. NB: It is recommended not to use these methods to interpolate more than 1000 vertices.
Public classSubDToBrepOptions
Options used for converting a SubD to a Brep
Public classSubDVertex
Single vertex of a SubD
Public classSumSurface
Represents a sum surface, or an extrusion of a curve along a curved path.
Public classSurface
Represents a base class that is common to most RhinoCommon surface types.

A surface represents an entity that can be all visited by providing two independent parameters, usually called (u, v), or sometimes (s, t).

Public classSurfaceCurvature
Maintains computed information for surface curvature evaluation.
Public classSurfaceFilletBase
New interactive FilletSrf
Public classSurfaceProxy
Provides a base class to brep faces and other surface proxies.
Public classSweepOneRail
Utility class for generating Breps by sweeping cross section curves over a single rail curve. Note, this class has been superseded by the Rhino.Geometry.Brep.CreateFromSweep static functions.
Public classSweepTwoRail Obsolete.
Utility class for generating Breps by sweeping cross section curves over two rail curves. Note, this class has been superseded by the Rhino.Geometry.Brep.CreateFromSweep static functions.
Public classTextDot
Represents a text dot, or an annotation entity with text that always faces the camera and always has the same size.

This class refers to the geometric element that is independent from the document.

Public classTextEntity
Public classUnroller
Represents the operation of unrolling a single surface.
Public classVolumeMassProperties
Contains static initialization methods and allows access to the computed metrics of volume, volume centroid and volume moments in in solid meshes, in solid surfaces and in solid (closed) boundary representations.
Structures
  StructureDescription
Public structureArc
Represents the value of a plane, two angles and a radius in a sub-curve of a three-dimensional circle.

The curve is parameterized by an angle expressed in radians. For an IsValid arc the total subtended angle AngleRadians() = Domain()(1) - Domain()(0) must satisfy 0 < AngleRadians() < 2*Pi

The parameterization of the Arc is inherited from the Circle it is derived from. In particular

t -> center + cos(t)*radius*xaxis + sin(t)*radius*yaxis

where xaxis and yaxis, (part of Circle.Plane) form an orthonormal frame of the plane containing the circle.

Public structureBoundingBox
Represents the value of two points in a bounding box defined by the two extreme corner points.

This box is therefore aligned to the world X, Y and Z axes.

Public structureBox
Represents the value of a plane and three intervals in an orthogonal, oriented box that is not necessarily parallel to the world Y, X, Z axes.
Public structureCircle
Represents a circle in 3D.

The values used are a radius and an orthonormal frame of the plane containing the circle, with origin at the center.

The circle is parameterized by radians from 0 to 2 Pi given by

t -> center + cos(t)*radius*xaxis + sin(t)*radius*yaxis

where center, xaxis and yaxis define the orthonormal frame of the circle plane.

Public structureComponentIndex
Represents an index of an element contained in another object.
Public structureComponentStatus
Provides information about selection, highlighting, visibility, editability and integrity states of a component.

This structure is immutable.

Public structureCone
Represents the center plane, radius and height values in a right circular cone.
Public structureControlPoint
Represents control point geometry with three-dimensional position and weight.
Public structureCylinder
Represents the values of a plane, a radius and two heights -on top and beneath- that define a right circular cylinder.
Public structureEllipse
Represents the values of a plane and the two semi-axes radii in an ellipse.
Public structureInterval
Represents an interval in one-dimensional space, that is defined as two extrema or bounds.
Public structureLine
Represents the value of start and end points in a single line segment.
Public structureMeshCheckParameters
Output of a mesh checking operations.
Public structureMeshFace
Represents the values of the four indices of a mesh face quad.

If the third and fourth values are the same, this face represents a triangle.

Public structureMeshThicknessMeasurement
Thickness measurement used in the mesh thickness solver.
Public structurePlane
Represents the value of a center point and two axes in a plane in three dimensions.
Public structurePoint2d
Represents the two coordinates of a point in two-dimensional space, using Double-precision floating point numbers.
Public structurePoint2f
Represents the two coordinates of a point in two-dimensional space, using Single-precision floating point numbers.
Public structurePoint3d
Represents the three coordinates of a point in three-dimensional space, using Double-precision floating point values.
Public structurePoint3f
Represents the three coordinates of a point in three-dimensional space, using Single-precision floating point numbers.
Public structurePoint4d
Represents the four coordinates of a point in four-dimensional space.

The W (fourth) dimension is often considered the weight of the point as seen in 3D space.

Public structureQuaternion
Represents the four coefficient values in a quaternion.

The first value a is the real part, while the rest multiplies i, j and k, that are imaginary.

quaternion = a + bi + cj + dk

Public structureRay3d
Represents an immutable ray in three dimensions, using position and direction.
Public structureRectangle3d
Represents the values of a plane and two intervals that form an oriented rectangle in three dimensions.
Public structureSphere
Represents the plane and radius values of a sphere.
Public structureTorus
Represents the value of a plane and two radii in a torus that is oriented in three-dimensional space.
Public structureTransform
Represents the values in a 4x4 transform matrix.

This is parallel to C++ ON_Xform.

Public structureTriangle3d
Represents a triangle, modeled using double three points that use double-precision floating point numbers.
Public structureVector2d
Represents the two components of a vector in two-dimensional space, using Double-precision floating point numbers.
Public structureVector2f
Represents the two components of a vector in two-dimensional space, using Single-precision floating point numbers.
Public structureVector3d
Represents the three components of a vector in three-dimensional space, using Double-precision floating point numbers.
Public structureVector3f
Represents the three components of a vector in three-dimensional space, using Single-precision floating point numbers.
Enumerations
  EnumerationDescription
Public enumerationAnnotationType
ON::AnnotationType identifies the type of an annotation object derived from ON_Annotation.
Public enumerationBlendContinuity
Used in curve and surface blending and matching functions.
Public enumerationBlendType
Blend types used for creating filleted Brep edges
Public enumerationBrepFaceShrinkDisableSide
Defines bitwise mask flags indicating what side of a surface to not shrink.
Public enumerationBrepLoopType
Each brep loop has a defined type, e.g. outer, inner or point on surface.
Public enumerationBrepSolidOrientation
Enumerates all possible Solid Orientations for a Brep.
Public enumerationBrepTrimType
Each brep trim has a defined type.
Public enumerationComponentIndexType
Defines enumerated values to represent component index types.
Public enumerationConcavity
Enumerates the possible types of edge concavity types.
Public enumerationConicSectionType
Defines enumerated values for types of conic sections.
Public enumerationContinuity
Provides enumerated values for continuity along geometry, such as continuous first derivative or continuous unit tangent and curvature.
Public enumerationCode exampleCurveEnd
Defines the extremes of a curve through a flagged enumeration.
Public enumerationCurveEvaluationSide
Defines enumerated values for the options that defines a curve evaluation side when evaluating kinks.
Public enumerationCurveExtensionStyle
Defines enumerated values for styles to use during curve extension, such as "Line", "Arc" or "Smooth".
Public enumerationCurveKnotStyle
Defines enumerated values for knot spacing styles in interpolated curves.
Public enumerationCurveOffsetCornerStyle
Defines enumerated values for all implemented corner styles in curve offsets.
Public enumerationCurveOffsetEndStyle
Defines enumerated values for all implemented end styles in curve offsets.
Public enumerationCurveOrientation
Defines enumerated values for closed curve orientations.
Public enumerationCurveSimplifyOptions
Enumerates the options to use when simplifying a curve.
Public enumerationDimensionForceArrow
OBSOLETE enum do not use.
Public enumerationDimensionForceText
OBSOLETE enum do not use.
Public enumerationDistancingMode
Defines how offset and similar operations should work.
Public enumerationEdgeAdjacency
Enumerates all possible Topological Edge adjacency types.
Public enumerationExtrudeCornerType
Corner types used for creating a tapered extrusion
Public enumerationFilletSurfaceSplitType
RhinoFilletSurfaceSplitType
Public enumerationHiddenLineDrawingPointVisibility
The different types of HiddenLineObjectPoint visibility
Public enumerationHiddenLineDrawingSegmentSideFill
When a silhouette is projected on the image plane (determined by the camera location or direction), and projects to a curve (not a point), the image area to the left or right of a projected silhouette curve is filled with either the surface or a void.
Public enumerationHiddenLineDrawingSegmentVisibility
The different types of HiddenLineDrawingSegment visibility
Public enumerationIsoStatus
Defines enumerated values for isoparametric curve direction on a surface, such as X or Y, and curve sides, such as North or West boundary.

Note: odd values are all x-constant; even values > 0 are all y-constant.

Public enumerationKnotStyle
Knot styles for NURBS curves and surfaces. If a knot vector meets the conditions of two styles, then the style with the lowest value is used.
Public enumerationLightAttenuation
Types of light attenuation available.
Public enumerationLightStyle
Defines enumerated values to represent light styles or types, such as directional or spotlight.
Public enumerationLoftType
Specifies enumerated constants for all supported loft types.
Public enumerationMeshExtruderFaceDirectionMode
Defines how mesh extruder decides orients faces
Public enumerationMeshExtruderParameterMode
Parameter mode for creating texture coordinates and surface parameters
Public enumerationMeshingParameterStyle
Type of Mesh Parameters used by the RhinoDoc for meshing objects
Public enumerationMeshingParameterTextureRange
Defines how to pack render/meshes textures.
Public enumerationMeshPipeCapStyle
Enumerates methods to end a mesh pipe.
Public enumerationMeshType
Defines enumerated values for various mesh types.
Public enumerationMeshUnwrapMethod
Unwrapping method used
Public enumerationNurbsCurveNurbsCurveEndConditionType
What end conditions to set
Public enumerationOrdinateDimensionMeasuredDirection
Ordinate dimension measures x or y direction
Public enumerationPipeCapMode
Styles used for creating Brep pipes.
Public enumerationPlaneFitResult
Enumerates all possible outcomes of a Least-Squares plane fitting operation.
Public enumerationPointContainment
Defines enumerated values for closed curve/point spatial relationships.
Public enumerationPointFaceRelation
Enumerates the possible point/BrepFace spatial relationships.
Public enumerationPreserveEnd
Preserves, or maintains, the shape of the opposite the one being edited.
Public enumerationQuadRemeshSymmetryAxis
Symmetrical meshing axis
Public enumerationRailType
Rail types used for creating filleted Brep edges
Public enumerationRefitTrimKnotMode
The mode for adding kinots to the surface for fitting
Public enumerationRefitTrimSectionMode
The mode for dividing the surface into sections
Public enumerationRegionContainment
Defines enumerated values for closed curve/closed curve relationships.
Public enumerationSilhouetteType
Enumerates the different types of silhouettes and their origins.
Public enumerationSmoothingCoordinateSystem
The direction of the smoothing used by Curve, Surface, and Mesh Smooth.
Public enumerationSquishDeformation
The types of deformation allowed in the squish process
Public enumerationSquishFlatteningAlgorithm
Represents the type of flattening to use
Public enumerationSubDNurbsSurfaceType
ON_SubD::NurbsSurfaceType specifies what type of NURBS surfaces are returned by ON_SubD.GetSurfaceNurbsFragments()
Public enumerationSubDAutomaticMeshToSubDContext
ON_SubD::AutomaticMeshToSubDContext identifies a context where meshes can automatically be converted to subds.
Public enumerationSubDChainType
SubD::ChainType specifies what edge and vertex tag tests are used when creating edge chains.
Public enumerationSubDComponentLocation
The ON_SubDComponentLocation enum is used when an ON_SubD component is referenced and it is important to distinguish between the component's location in the SubD control net and its location in the SubD limit surface.
Public enumerationSubDCreationOptionsConcaveCornerOption
Defines how concave corners are treated.
Public enumerationSubDCreationOptionsConvexCornerOption
Defines how convex corners are treated.
Public enumerationSubDCreationOptionsInteriorCreaseOption
Specifies the test used to determine when an interior mesh edge generates an interior SubD creased edge.
Public enumerationSubDCreationOptionsTextureCoordinateOption
Specifies how texture coordinate information is transferred from the mesh to the SubD.
Public enumerationSubDDisplayParametersDensity
Density enumeration
Public enumerationSubDEdgeTag
ON_SubDEdgeTag identifies the type of subdivision edge. Different tags use different subdivision algorithms to calculate the subdivision point.
Public enumerationSubDEdgeType
ON_SubDEdgeType describes a subdivision edge. ON_SubDEdgeType is typically used when generating text descriptions or filtering edges during selection processes. Do not confuse ON_SubDEdgeType and ON_SubDEdgeTag. The unique types are single bits and suitable for use in bitwise logic.
Public enumerationSubDEndCapStyle
ON_SubDEndCapStyle enumerates the type of end caps functions like ON_SubD::CreateCylinder will create. Use ON_SubDEndCapStyleFromUnsigned(integer value) to convert integer values to an ON_SubDEndCapStyle. Use ON_SubDEndCapStyleToString(end_cap_style) to convert ON_SubDEndCapStyle values to string descriptions.
Public enumerationSubDFriendlyKnotType
ON_SubD::SubDFriendlyKnotType identifies the types of subd friendly NURBS knot vectors. SubD friendly NURBS curves and surfacaes are always cubic and nonrational. Any time there is a multiple knot, the 2nd derivative is zero at the corresponding parameter. SubD friendly NURBS curves are either periodic or have zero 2nd derivative at the ends.
Public enumerationSubDFromSurfaceMethods
ON_SubDFromSurfaceParameters::Method are ways to create a SubD from a surface.
Public enumerationSubDHashType
ON_SubDHashType used used to specify what type of SubD information is hashed (topology or geometry).
Public enumerationSubDPatchStyle
SubD::PatchStyle identifies the style of patch used to fill holes.
Public enumerationSubDSurfaceInterpolatorMaximumCounts
Stores maximum count values for the solver to work in reasonnable time.
Public enumerationSubDToBrepOptionsExtraordinaryVertexProcessOption
ON_SubDToBrepParameters::Vertex identifies the options for post processing extraorindary vertices.
Public enumerationSubDVertexFacetType
Summarizes the number of edges in faces in the whole object.
Public enumerationSubDVertexTag
ON_SubDVertexTag identifies the type of subdivision vertex. Different tags use different subdivision algorithms to determine where the subdivision point and limit point are located. There are toplological constraints that restrict which tags can be assigned.
Public enumerationSweepBlend
Blend types for creating swept surfaces
Public enumerationSweepFrame
Frame types for creating swept surfaces
Public enumerationSweepMiter
Miter types for creating swept surfaces
Public enumerationSweepRebuild
Rebuild types for creating swept surfaces
Public enumerationTextJustification
Specifies enumerated constants used to indicate the internal alignment and justification of text.
Public enumerationTextRunType
Public enumerationTransformRigidType
Lists all possible outcomes for rigid transformation.
Public enumerationTransformSimilarityType
Lists all possible outcomes for transform similarity.