Click or drag to resize

Ellipse Structure

Represents the values of a plane and the two semi-axes radii in an ellipse.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Ellipse : IEpsilonComparable<Ellipse>, 
	ICloneable

The Ellipse type exposes the following members.

Constructors
  NameDescription
Public methodEllipse(Plane, Double, Double)
Initializes a new ellipse from base plane and both principal radii.
Public methodEllipse(Point3d, Point3d, Point3d)
Initializes a new ellipse from a center point and the two semi-axes intersections.
Top
Properties
  NameDescription
Public propertyCenter
Gets or sets the center of the ellipse.
Public propertyFocalDistance
Gets the distance from the center to a focus.
Public propertyIsValid
Returns an indication of the validity of this ellipse.
Public propertyPlane
Gets or sets the base plane of the ellipse.
Public propertyRadius1
Gets or sets the radius of the ellipse along the base plane X semi-axis.
Public propertyRadius2
Gets or sets the radius of the ellipse along the base plane Y semi-axis.
Top
Methods
  NameDescription
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodGetFoci
Gets the foci. The foci are two points whose sum of distances from any point on the ellipse is always the same.
Public methodToNurbsCurve
Constructs a nurbs curve representation of this ellipse.

This is equivalent to calling NurbsCurve.CreateFromEllipse().

Top
See Also