Click or drag to resize

Sphere Structure

Represents the plane and radius values of a sphere.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Sphere : IEpsilonComparable<Sphere>

The Sphere type exposes the following members.

Constructors
  NameDescription
Public methodSphere(Plane, Double)
Initializes a new sphere given the plane of the equator circle and radius.
Public methodCode exampleSphere(Point3d, Double)
Initializes a new sphere given center point and radius.
Top
Properties
  NameDescription
Public propertyBoundingBox
Gets the world aligned bounding box for this Sphere. If the Sphere is Invalid, an empty box is returned.
Public propertyCenter
Gets or sets the center point of the sphere.
Public propertyDiameter
Gets or sets the diameter for this sphere.
Public propertyEquatorialPlane
Gets or sets the Equatorial plane for this sphere.
Public propertyIsValid
Gets a value that indicates whether the sphere is valid.
Public propertyNorthPole
Gets the point at the North Pole of the sphere.

This is the parameterization singularity that can be obtained, at V value +Math.Pi/2.

Public propertyRadius
Gets or sets the Radius for this sphere.
Public propertySouthPole
Gets the point at the South Pole of the sphere.

This is the parameterization singularity that can be obtained, at V value -Math.Pi/2.

Public propertyStatic memberUnset
Gets a sphere with invalid members.
Top
Methods
  NameDescription
Public methodClosestParameter
Finds the angle parameters on this sphere that are closest to a test point.
Public methodClosestPoint
Returns point on sphere that is closest to given point.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodStatic memberFitSphereToPoints
Attempts to fit a sphere to a collection of points.
Public methodLatitudeDegrees
Computes the parallel at a specific latitude angle.

The angle is specified in degrees.

Public methodLatitudeRadians
Computes the parallel at a specific latitude angle.

The angle is specified in radians.

Public methodLongitudeDegrees
Computes the meridian at a specific longitude angle.

The angle is specified in degrees.

Public methodLongitudeRadians
Computes the meridian at a specific longitude angle.

The angle is specified in radians.

Public methodNormalAt
Computes the normal at a specific angular location on the sphere.
Public methodPointAt
Evaluates the sphere at specific longitude and latitude angles.
Public methodRotate(Double, Vector3d)
Rotates the sphere about the center point.
Public methodRotate(Double, Vector3d, Point3d)
Rotates this sphere about a point and an axis.
Public methodRotate(Double, Double, Vector3d)
Rotates this sphere about the center point.
Public methodRotate(Double, Double, Vector3d, Point3d)
Rotates this sphere about a point and an axis.
Public methodToBrep
Converts this sphere is it Brep representation
Public methodToNurbsSurface
Converts this sphere to its NurbsSurface representation. This is synonymous with calling NurbsSurface.CreateFromSphere().
Public methodToRevSurface
Converts this Sphere to a RevSurface representation. This is synonymous with calling RevSurface.CreateFromSphere().
Public methodTransform
Transforms this sphere. Note that non-similarity preserving transformations cannot be applied to a sphere as that would result in an ellipsoid.
Public methodTranslate
Moves this sphere along a motion vector.
Top
See Also