Click or drag to resize

Sphere Properties

The Sphere type exposes the following members.

Properties
  NameDescription
Public propertyBoundingBox
Gets the world aligned bounding box for this Sphere. If the Sphere is Invalid, an empty box is returned.
Public propertyCenter
Gets or sets the center point of the sphere.
Public propertyDiameter
Gets or sets the diameter for this sphere.
Public propertyEquatorialPlane
Gets or sets the Equatorial plane for this sphere.
Public propertyIsValid
Gets a value that indicates whether the sphere is valid.
Public propertyNorthPole
Gets the point at the North Pole of the sphere.

This is the parameterization singularity that can be obtained, at V value +Math.Pi/2.

Public propertyRadius
Gets or sets the Radius for this sphere.
Public propertySouthPole
Gets the point at the South Pole of the sphere.

This is the parameterization singularity that can be obtained, at V value -Math.Pi/2.

Public propertyStatic memberUnset
Gets a sphere with invalid members.
Top
See Also