Click or drag to resize

SumSurface Class

Represents a sum surface, or an extrusion of a curve along a curved path.
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class SumSurface : Surface

The SumSurface type exposes the following members.

Constructors
  NameDescription
Protected methodSumSurface
Protected constructor for internal use.
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Public methodStatic memberCreate(Curve, Curve)
Constructs a new sum surface by extruding a curve A along a path B.
Public methodStatic memberCreate(Curve, Vector3d)
Constructs a new sum surface by extruding a curve in a specified direction.
Top
See Also