SurfaceGetSurfaceSize Method |
Gets an estimate of the size of the rectangle that would be created
if the 3d surface where flattened into a rectangle.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool GetSurfaceSize(
out double width,
out double height
)
Public Function GetSurfaceSize (
<OutAttribute> ByRef width As Double,
<OutAttribute> ByRef height As Double
) As Boolean
Parameters
- width
- Type: SystemDouble
corresponds to the first surface parameter. - height
- Type: SystemDouble
corresponds to the second surface parameter.
Return Value
Type:
Booleantrue if successful.
Examples
Re-parameterize a surface to minimize distortion in the map from parameter space to 3d.
Surface surf = ...;
double width, height;
if ( surf.GetSurfaceSize( out width, out height ) )
{
surf.SetDomain( 0, new ON_Interval( 0.0, width ) );
surf.SetDomain( 1, new ON_Interval( 0.0, height ) );
}
See Also