Click or drag to resize

Surface Methods

The Surface type exposes the following members.

Methods
  NameDescription
Public methodCode exampleClosestPoint
Input the parameters of the point on the surface that is closest to testPoint.
Public methodClosestSide
Gets the side that is closest, in terms of 3D-distance, to a U and V parameter.
Public methodStatic memberCreateExtrusion
Constructs a surface by extruding a curve along a vector.
Public methodStatic memberCreateExtrusionToPoint
Constructs a surface by extruding a curve to a point.
Public methodStatic memberCreatePeriodicSurface(Surface, Int32)
Constructs a periodic surface from a base surface and a direction.
Public methodStatic memberCreatePeriodicSurface(Surface, Int32, Boolean)
Constructs a periodic surface from a base surface and a direction.
Public methodStatic memberCreateRollingBallFillet(Surface, Surface, Double, Double)
Constructs a rolling ball fillet between two surfaces.
Public methodStatic memberCreateRollingBallFillet(Surface, Point2d, Surface, Point2d, Double, Double)
Constructs a rolling ball fillet between two surfaces.
Public methodStatic memberCreateRollingBallFillet(Surface, Boolean, Surface, Boolean, Double, Double)
Constructs a rolling ball fillet between two surfaces.
Public methodStatic memberCreateSoftEditSurface
Creates a soft edited surface from an existing surface using a smooth field of influence.
Public methodCode exampleCurvatureAt
Computes the curvature at the given UV coordinate.
Public methodDegree
Returns the maximum algebraic degree of any span (or a good estimate if curve spans are not algebraic).
Public methodDomain
Gets the domain in a direction.
Public methodEvaluate
Evaluates a surface mathematically.
Public methodExtend(Int32, Interval)
Analytically extends the surface to include the interval.
Public methodExtend(IsoStatus, Double, Boolean)
Extends an untrimmed surface along one edge.
Public methodFit
Fits a new surface through an existing surface.
Public methodFitCurveToSurface
Public methodCode exampleFrameAt
Computes the orient plane on a surface given a U and V parameter.

This is the simple evaluation call with no error handling.

Public methodGetNextDiscontinuity(Int32, Continuity, Double, Double, Double)
Searches for a derivative, tangent, or curvature discontinuity.
Public methodGetNextDiscontinuity(Int32, Continuity, Double, Double, Double, Double, Double)
Searches for a derivative, tangent, or curvature discontinuity.
Public methodGetNurbsFormParameterFromSurfaceParameter
Translates a parameter from the current surface to the parameter space of the surface returned by ToNurbsSurface.
Public methodGetSpanVector
Gets array of span "knots".
Public methodGetSurfaceParameterFromNurbsFormParameter
Translates a parameter from a value on the surface returned by ToNurbsSurface to the current surface.
Public methodCode exampleGetSurfaceSize
Gets an estimate of the size of the rectangle that would be created if the 3d surface where flattened into a rectangle.
Public methodHasNurbsForm
Is there a NURBS surface representation of this surface.
Public methodInterpolatedCurveOnSurface
Constructs an interpolated curve on a surface, using 3D points.
Public methodInterpolatedCurveOnSurfaceUV(IEnumerablePoint2d, Double)
Returns a curve that interpolates points on a surface. The interpolant lies on the surface.
Public methodInterpolatedCurveOnSurfaceUV(IEnumerablePoint2d, Double, Boolean, Int32)
Returns a curve that interpolates points on a surface. The interpolant lies on the surface.
Public methodIsAtSeam
Tests if a surface parameter value is at a seam.
Public methodIsAtSingularity
Tests if a surface parameter value is at a singularity.
Public methodIsClosed
Gets a value indicating if the surface is closed in a direction.
Public methodIsCone
Determines if the surface is a portion of a cone within RhinoMath.ZeroTolerance.
Public methodIsCone(Double)
Determines if the surface is a portion of a cone within a given tolerance.
Public methodIsContinuous
Tests continuity at a surface parameter value.
Public methodIsCylinder
Determines if the surface is a portion of a cylinder within RhinoMath.ZeroTolerance.
Public methodIsCylinder(Double)
Determines if the surface is a portion of a cylinder within a given tolerance.
Public methodIsIsoparametric(BoundingBox)
Determines if a 2d bounding box is isoparametric in the parameter space of this surface.
Public methodIsIsoparametric(Curve)
Determines if a 2d curve is isoparametric in the parameter space of this surface.
Public methodIsIsoparametric(Curve, Interval)
Determines if a 2D curve is isoparametric in the parameter space of this surface.
Public methodCode exampleIsoCurve
Gets isoparametric curve.
Public methodIsPeriodic
Gets a value indicating if the surface is periodic in a direction (default is false).
Public methodCode exampleIsPlanar
Tests a surface to see if it is planar to zero tolerance.
Public methodIsPlanar(Double)
Tests a surface to see if it is planar to a given tolerance.
Public methodIsSingular
true if surface side is collapsed to a point.
Public methodIsSphere
Determines if the surface is a portion of a sphere within RhinoMath.ZeroTolerance.
Public methodIsSphere(Double)
Determines if the surface is a portion of a sphere within a given tolerance.
Public methodIsTorus
Determines if the surface is a portion of a torus within RhinoMath.ZeroTolerance.
Public methodIsTorus(Double)
Determines if the surface is a portion of a torus within a given tolerance.
Public methodLocalClosestPoint
Find parameters of the point on a surface that is locally closest to the testPoint. The search for a local close point starts at seed parameters.
Public methodCode exampleNormalAt
Computes the surface normal at a point.

This is the simple evaluation call - it does not support error handling.

Public methodOffset
Constructs a new surface which is offset from the current surface.
Public methodPointAt
Evaluates a point at a given parameter.
Public methodPullback(Curve, Double)
Pulls a 3d curve back to the surface's parameter space.
Public methodPullback(Curve, Double, Interval)
Pulls a 3d curve back to the surface's parameter space.
Public methodPushup(Curve, Double)
Computes a 3d curve that is the composite of a 2d curve and the surface map.
Public methodPushup(Curve, Double, Interval)
Computes a 3d curve that is the composite of a 2d curve and the surface map.
Public methodRebuild
Rebuilds an existing surface to a given degree and point count.
Public methodRebuildOneDirection
Rebuilds an existing surface with a new surface to a given point count in either the u or v directions independently.
Public methodRefitSimplySplitSurface
This routine accepts a 3-d trim curve (trimCrv3d). The trim curve is assumed to run from one surface edge to the opposite edge; this is referred to as a "simple" trim curve, roughly parallel to one of the srf directions (either u or v). We refer to that parameter as the "trim parameter". The routine splits the surface via the trim curve, and then refits either side ("upper" = "above the trim", and "lower" = "below the trim") as a set of untrimmed Nurbs surfaces. The idea is to retain, as much as possible, the Nurbs structure of srf, especially in the trim parameter.
Public methodRefitSplit
Splits the surface into two and refits the split edge
Public methodReverse(Int32)
Reverses parameterization Domain changes from [a,b] to [-b,-a]
Public methodReverse(Int32, Boolean)
Same as Reverse, but if inPlace is set to true this Surface is modified instead of a new copy being created.
Public methodSetDomain
Sets the domain in a direction.
Public methodShortPath
Constructs a geodesic between 2 points, used by ShortPath command in Rhino.
Public methodSmooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem)
Smooths a surface by averaging the positions of control points in a specified region.
Public methodSmooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem, Plane)
Smooths a surface by averaging the positions of control points in a specified region.
Public methodSpanCount
Gets number of smooth nonempty spans in the parameter direction.
Public methodSplit
Splits (divides) the surface into two parts at the specified parameter
Public methodToBrep
Converts the surface into a Brep.
Public methodToNurbsSurface
Gets a NURBS surface representation of this surface. Default tolerance of 0.0 is used.
Public methodToNurbsSurface(Double, Int32)
Gets a NURBS surface representation of this surface.
Public methodTranspose
Transposes surface parameterization (swap U and V)
Public methodTranspose(Boolean)
Transposes surface parameterization (swap U and V)
Public methodTrim
Constructs a sub-surface that covers the specified UV trimming domain.
Public methodTryGetCone(Cone)
Tests a surface to see if it is a portion of a cone within RhinoMath.ZeroTolerance and return the cone.
Public methodTryGetCone(Cone, Double)
Tests a surface to see if it is a portion of a cone and returns the cone.
Public methodTryGetCylinder(Cylinder)
Tests a surface to see if it is a portion of a cylinder within RhinoMath.ZeroTolerance and return the cylinder.
Public methodTryGetCylinder(Cylinder, Double)
Tests a surface to see if it is a portion of a cylinder and return the infinite cylinder.
Public methodTryGetFiniteCylinder
Tests a surface with the assumption that it might be a right circular cylinder and returns this geometry.
Public methodTryGetPlane(Plane)
Tests a surface for planarity and return the plane.
Public methodCode exampleTryGetPlane(Plane, Double)
Tests a surface for planarity and return the plane.
Public methodTryGetSphere(Sphere)
Test a surface to see if it is a portion of a sphere and return the sphere.
Public methodTryGetSphere(Sphere, Double)
Test a surface to see if it is a portion of a sphere and return the sphere.
Public methodTryGetTorus(Torus)
Tests a surface to see if it is a portion of a torus within RhinoMath.ZeroTolerance and returns the torus.
Public methodTryGetTorus(Torus, Double)
Tests a surface to see if it is a portion of a torus and returns the torus.
Public methodVariableOffset(Double, Double, Double, Double, Double)
Copies a surface so that all locations at the corners of the copied surface are specified distances from the original surface.
Public methodVariableOffset(Double, Double, Double, Double, IEnumerablePoint2d, IEnumerableDouble, Double)
Copies a surface so that all locations at the corners, and from specified interior locations, of the copied surface are specified distances from the original surface.
Top
See Also