SurfaceTryGetSphere Method (Sphere, Double) |
Test a surface to see if it is a portion of a sphere and return the sphere.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool TryGetSphere(
out Sphere sphere,
double tolerance
)
Public Function TryGetSphere (
<OutAttribute> ByRef sphere As Sphere,
tolerance As Double
) As Boolean
Parameters
- sphere
- Type: Rhino.GeometrySphere
On success, the sphere parameters are filled in. - tolerance
- Type: SystemDouble
tolerance to use when checking.
Return Value
Type:
Booleantrue if the surface is a portion of a sphere.
See Also