CommonObject Class |
Namespace: Rhino.Runtime
The CommonObject type exposes the following members.
Name | Description | |
---|---|---|
CommonObject |
Allows construction from inheriting classes.
| |
CommonObject(SerializationInfo, StreamingContext) |
Protected constructor for internal use.
|
Name | Description | |
---|---|---|
Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
| |
HasUserData |
Gets true if this class has any custom information attached to it through UserData.
| |
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
| |
IsValid | Tests an object to see if it is valid. | |
PerformCorruptionTesting |
Used to test ON_Object* pointers to see if they are a brep or mesh that is corrupt enough to crash Rhino.
| |
UserData |
List of custom information that is attached to this class.
| |
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use shareable set of information.
|
Name | Description | |
---|---|---|
ConstructConstObject |
Assigns a parent object and a sub-object index to this.
| |
Dispose |
Actively reclaims unmanaged resources that this instance uses.
| |
Dispose(Boolean) |
For derived class implementers.
This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method. | |
EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
| |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.) | |
FromBase64String |
Create a CommonObject instance from a Base64 encoded string. This is typically the values
used when passing common objects around as JSON data
| |
FromJSON(DictionaryString, String) |
Create a CommonObject instance from a JSON dictionary
| |
FromJSON(String) |
Create a CommonObject instance from a JSON string
| |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
| |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
| |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
NonConstOperation |
For derived classes implementers.
Defines the necessary implementation to free the instance from being constant. | |
OnSwitchToNonConst |
Is called when a non-constant operation first occurs.
| |
ToJSON |
Create a JSON string representation of this object
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) |