Click or drag to resize

RenderSettings Class

Contains settings used in rendering.
Inheritance Hierarchy

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RenderSettings : CommonObject

The RenderSettings type exposes the following members.

Constructors
  NameDescription
Public methodRenderSettings
Initialize a new instance of the RenderSettings class.
Public methodRenderSettings(RenderSettings)
Initialize new instance of the RenderSettings class.
Top
Properties
  NameDescription
Public propertyAmbientLight
Gets or sets the ambient light color used in rendering.
Public propertyAntialiasLevel
Gets or sets anti-alias level, used for render quality
Public propertyBackgroundColorBottom
Gets or sets the background bottom color used in rendering.
Public propertyBackgroundColorTop
Gets or sets the background top color used in rendering.

Sets also the background color if a solid background color is set.

Public propertyBackgroundStyle
How the viewport's background should be filled.
Public propertyDepthCue
Gets or sets a value indicating whether to render using depth cues.

These are clues to help the perception of position and orientation of objects in the image.

Public propertyDithering
If this object is associated with a document, this gets the document dithering. If this object is associated with a File3dm, this gets the File3dm's dithering. Otherwise it gets a 'free-floating' dithering object.
Public propertyFlatShade
Gets or sets a value indicating whether to render using flat shading.
Public propertyGroundPlane
If this object is associated with a document, this gets the document ground plane. If this object is associated with a File3dm, this gets the File3dm's ground plane. Otherwise it gets a 'free-floating' ground plane object.
Public propertyImageDpi
Number of dots/inch (dots=pixels) to use when printing and saving bitmaps. The default is 72.0 dots/inch.
Public propertyImageSize
Gets or sets a value indicating the size of the rendering result if UseViewportSize is set to false. If UseViewportSize is set to true, then this value is ignored.
Public propertyImageUnitSystem
unit system to use when converting image pixel size and DPI information into a print size. Default = inches
Public propertyLinearWorkflow
If this object is associated with a document, this gets the document linear workflow. If this object is associated with a File3dm, this gets the File3dm's linear workflow. Otherwise it gets a 'free-floating' linear workflow object.
Public propertyNamedView
Get or set the given named view
Public propertyPostEffects
If this object is associated with a document, this gets the document post effect data collection. If this object is associated with a File3dm, this gets the File3dm's post effect data collection. Otherwise it gets a 'free-floating' post effect data collection object.
Public propertyRenderAnnotations
Gets or sets a value indicating whether to instruct the rendering engine to show annotations, such as linear dimensions or angular dimensions.
Public propertyRenderBackfaces
Gets or sets a value indicating whether to render back faces.
Public propertyRenderChannels
If this object is associated with a document, this gets the document render channels. Otherwise it gets a 'free-floating' render channels object.
Public propertyRenderCurves
Gets or sets a value indicating whether to instruct the rendering engine to show curves.
Public propertyRenderIsoparams
Gets or sets a value indicating whether to instruct the rendering engine to show isocurves.
Public propertyRenderMeshEdges
Gets or sets a value indicating whether to instruct the rendering engine to show mesh edges.
Public propertyRenderPoints
Gets or sets a value indicating whether to instruct the rendering engine to show points.
Public propertyRenderSource
Public propertySafeFrame
If this object is associated with a document, this gets the document safe-frame. If this object is associated with a File3dm, this gets the File3dm's safe-frame. Otherwise it gets a 'free-floating' safe-frame object.
Public propertyScaleBackgroundToFit
Gets or sets a value indicating whether to scale the wallpaper in the background or not. This is meaningful only if the viewport has a wallpaper and render settings are set to render Wallpaper into the background.
Public propertyShadowmapLevel
0=none, 1=normal, 2=best.
Public propertySkylight
If this object is associated with a document, this gets the document skylight. If this object is associated with a File3dm, this gets the File3dm's skylight. Otherwise it gets a 'free-floating' skylight object.
Public propertySnapshot
Set or get the given snapshot view
Public propertySpecificViewport
Set or get the given specific viewport
Public propertySun
If this object is associated with a document, this gets the document sun. If this object is associated with a File3dm, this gets the File3dm's sun. Otherwise it gets a 'free-floating' sun object.
Public propertyTransparentBackground
Gets or sets whether rendering should be done with transparent background.
Public propertyUseHiddenLights
Gets or sets a value indicating whether to render using lights that are on layers that are off.
Public propertyUseViewportSize
Gets or sets a value indicating whether to use the resolution of the viewport being rendered or ImageSize when rendering
Top
Methods
  NameDescription
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodDuplicate
Makes a free-floating copy of the object.
Public methodRenderEnvironment
Get the render environment for a particular usage. Only works if this render settings is in a document. If usage is Background and the background mode is set to 'Solid Color' or 'Gradient' (i.e., not 'Environment'), then null will be returned.
Public methodRenderEnvironmentId
Get the id of the render environment for a particular usage. If usage is Background and the background mode is set to 'Solid Color' or 'Gradient' (i.e., not 'Environment'), then Guid.Empty will be returned.
Public methodRenderEnvironmentOverride
For usage background, this checks if the background style is set to 'Environment'. For reflection and skylighting, it checks if the relevant custom override is enabled.
Public methodSetRenderEnvironment
Set the render environment for a particular usage. Passing null for usage Skylighting or Reflection will turn the override for that usage off.
Public methodSetRenderEnvironmentId
Set the id of the render environment for a particular usage. Passing Guid.Empty for usage Skylighting or Reflection will turn the override for that usage off.
Public methodSetRenderEnvironmentOverride
Set the given environment override on/off. Only works for usage Reflection and Skylighting.
Top
See Also