Click or drag to resize

RenderSettings Methods

The RenderSettings type exposes the following members.

Methods
  NameDescription
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodDuplicate
Makes a free-floating copy of the object.
Public methodRenderEnvironment
Get the render environment for a particular usage. Only works if this render settings is in a document. If usage is Background and the background mode is set to 'Solid Color' or 'Gradient' (i.e., not 'Environment'), then null will be returned.
Public methodRenderEnvironmentId
Get the id of the render environment for a particular usage. If usage is Background and the background mode is set to 'Solid Color' or 'Gradient' (i.e., not 'Environment'), then Guid.Empty will be returned.
Public methodRenderEnvironmentOverride
For usage background, this checks if the background style is set to 'Environment'. For reflection and skylighting, it checks if the relevant custom override is enabled.
Public methodSetRenderEnvironment
Set the render environment for a particular usage. Passing null for usage Skylighting or Reflection will turn the override for that usage off.
Public methodSetRenderEnvironmentId
Set the id of the render environment for a particular usage. Passing Guid.Empty for usage Skylighting or Reflection will turn the override for that usage off.
Public methodSetRenderEnvironmentOverride
Set the given environment override on/off. Only works for usage Reflection and Skylighting.
Top
See Also