Click or drag to resize

CommonObject Methods

The CommonObject type exposes the following members.

Methods
  NameDescription
Protected methodConstructConstObject
Assigns a parent object and a sub-object index to this.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodEnsurePrivateCopy
If you want to keep a copy of this class around by holding onto it in a variable after a command completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can call this function as many times as you want.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodStatic memberFromBase64String
Create a CommonObject instance from a Base64 encoded string. This is typically the values used when passing common objects around as JSON data
Public methodStatic memberFromJSON(DictionaryString, String)
Create a CommonObject instance from a JSON dictionary
Public methodStatic memberFromJSON(String)
Create a CommonObject instance from a JSON string
Public methodGetObjectData
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public methodIsValidWithLog
Determines if an object is valid. Also provides a report on errors if this object happens not to be valid.
Protected methodNonConstOperation
For derived classes implementers.

Defines the necessary implementation to free the instance from being constant.

Protected methodOnSwitchToNonConst
Is called when a non-constant operation first occurs.
Public methodToJSON
Create a JSON string representation of this object
Top
See Also