Click or drag to resize

Rhino.Runtime Namespace

[Missing <summary> documentation for "N:Rhino.Runtime"]

Classes
  ClassDescription
Public classAnalytics
Provides tools for sending Google Analytics events using the Measurement Protocol. See https://developers.google.com/analytics/devguides/collection/protocol/v1/devguide#event for details.
Public classAssemblyResolver
Assembly Resolver for the Rhino App Domain.
Public classCommonObject
Base class for .NET classes that wrap C++ unmanaged Rhino classes.
Public classCorruptGeometryException
Thrown when Rhino finds a brep or mesh that will cause a crash if used for calculations.
Public classDocumentCollectedException
Represents the error that happen when a class user attempts to execute a modifying operation on an object that has been added to a document.
Public classHostUtils
Contains static methods to deal with the runtime environment.
Public classInterop
Contains static methods to marshal objects between RhinoCommon and legacy Rhino_DotNet or C++.
Public classLicenseStateChangedEventArgs
Passed to LicenseStateChanged event on RhinoApp
Public classNamedParametersEventArgs
Dictionary style class used for named callbacks from C++ -> .NET
Public classNotLicensedException
Exception thrown when calling functions in RhinoCommon and the application is executing without a license
Public classPythonCompiledCode
Represents scripting compiled code.
Public classPythonScript
Represents a Python script.
Public classRdkNotLoadedException
Is thrown when the RDK is not loaded.
Public classRiskyAction
Defines risky actions that need to be reported in crash exceptions
Public classSkin
Represents a customized environment that changes the appearance of Rhino.

Skin DLLs must contain a single class that derives from the Skin class.

Public classTextFields
This Class Processes Text Field Functions
Public classTextFieldsInstanceAttributeField
Public classViewCaptureWriter
Callback system used by SVG and PDF exporter to generate documents. Not intended for general SDK usage
Public classViewCaptureWriterPen
Public classZooClientParameters
ZooClientParameters is a read-only set of parameters that control the flow of licensing inside ZooClient. Because this class flows through a number of other classes, functions, and UI, it is read-only so that inadvertent changes are not made to the data as it propagates from the caller.
Structures
Interfaces
  InterfaceDescription
Public interfaceIPlatformServiceLocator
Get platform specific services that are used internally for general cross platform funtions in RhinoCommon. This includes services like localization and GUI components that have concrete implementations in the RhinoWindows or RhinoMac assemblies
Public interfaceIShrinkWrapService
Internal interface used by ShrinkWrap functions
Public interfaceIZooClientUtilities
Interface implemented in ZooClient and added to Rhino via dependency injection
Delegates
  DelegateDescription
Public delegateHostUtilsExceptionReportDelegate
Represents a reference to a method that will be called when an exception occurs.
Public delegateHostUtilsSendLogMessageToCloudDelegate
Represents a reference to a method that will be called when an exception occurs.
Public delegateViewCaptureWriterFillProc
Public delegateViewCaptureWriterSetClipRectProc
Public delegateViewCaptureWriterVectorArcProc
Public delegateViewCaptureWriterVectorBitmapProc
Public delegateViewCaptureWriterVectorClipPathProc
Public delegateViewCaptureWriterVectorFillPolygonProc
Public delegateViewCaptureWriterVectorGradientProc
Public delegateViewCaptureWriterVectorPathProc
Public delegateViewCaptureWriterVectorPointProc
Public delegateViewCaptureWriterVectorPolylineProc
Public delegateViewCaptureWriterVectorRoundedRectProc
Public delegateViewCaptureWriterVectorStringProc
Enumerations
  EnumerationDescription
Public enumerationAdvancedSetting
Advanced setting Id
Public enumerationHostUtilsLogMessageType
Represents the type of message that is being sent to the OnSendLogMessageToCloud event
Public enumerationImportOptionsSections
Standard CRhImportOptions sections to import
Public enumerationLicenseTypes
Different licensing modes that Rhino can run in
Public enumerationMode
Contains enumerated constant values to represent Rhino's Runtime Mode.
Public enumerationViewCaptureWriterPointType