Click or drag to resize

AdvancedSetting Enumeration

Advanced setting Id

Namespace:  Rhino.Runtime
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public enum AdvancedSetting
Members
  Member nameValueDescription
UseNewDraftAngleAnalysisUi0 UseNewDraftAngleAnalysisUi bool Value, defaults to true
UseCompressionWhenSaving1 Use compressed buffers when saving 3dm files (default is true).
TestAdvancedString2 String value, defaults to "test string"
TestAdvancedInt3 Integer value, defaults 123
PdfOptionalContentGroups4 How optional content should be included when exporting PDF files
LeaveFloatingPanelsHiddenOnMac5 Bool value used on Mac to satisfy a user request to hide floating stuff when a command starts and leave it hidden when the command ends. This is false by default. https://mcneel.myjetbrains.com/youtrack/issue/RH-57945
DisableFileWatchers6 Disable file watchers, using to diagnose Mac Rhino mystery crashes https://mcneel.myjetbrains.com/youtrack/issue/RH-52805
EnableCheckForUpdates7 Auto check for update, enabled by default on Mac, does not show up in Windows https://mcneel.myjetbrains.com/youtrack/issue/RH-60427
LeftJustifyNumericText8 Mainly an issue on Windows; there are different numeric controls scattered across the product and no consistent text alignment. This is an attempt to provide a way to control the preferred alignment style.
EnableWindowsGestures9 https://mcneel.myjetbrains.com/youtrack/issue/RH-62173 Disable gestures for Windows views for a customer who was complaining when upgrading.
MakeInteriorNgonVertexesSelectable10 Set this to false if you only want boundary vertexes selectable when you run PointsOn. https://mcneel.myjetbrains.com/youtrack/issue/RH-62140
MacDisplayOldVersionAutosaveWarning11 Set this to true if you want to be warned about autosave for old file versions on Mac. https://mcneel.myjetbrains.com/youtrack/issue/RH-62359
UseNewMissingFontUI12 Set this to true if you want to be use the new missing font mapping UI. https://mcneel.myjetbrains.com/youtrack/issue/RH-62642
ExportDocumentUserText13 Set to true to write document user text on Export and Copy/Paste. Set to false to not write document user text (default). https://mcneel.myjetbrains.com/youtrack/issue/RH-63589
CommandsToIgnoreWhenAutoHidingToolPalettes14 String list of command names to ignore when closing tool-palette on begin command. https://mcneel.myjetbrains.com/youtrack/issue/RH-65131
DisplayNonOriginModelBasepointWarning15 Set this to true if you want to be warned about ModelBasepoints that are not set to the origin on open/import. https://mcneel.myjetbrains.com/youtrack/issue/RH-67520
UseEntireWidthForTopBand16 Use the entire client width for top and bottom dock sites https://mcneel.myjetbrains.com/youtrack/issue/RH-67783
UseMFCMenuBar17 Experimenting with using a CMFCMenuBar to host main frame menu with a CMFCVisualManager derived class for styling the menu. https://mcneel.myjetbrains.com/youtrack/issue/RH-70314
IgnoreRUIPlatform18 Will ignore the platforms attribute in RUI files when set. Requires restarting Rhino to take affect. https://mcneel.myjetbrains.com/youtrack/issue/RH-70777
EnableMcNeelOnlyFeatures19 Enable McNeel only features for a particular user
UseRhinoColorsForModalDialogs20 Enable to use Eto Appearance page only
AcadExportSelectUnexportableObjects21 Set to true to select objects that could not be exported to DWG, either becuase the object was invalid or the exporter failed for whatever reason. https://mcneel.myjetbrains.com/youtrack/issue/RH-77693
AcadExportSortLayers22 Temporary advanced settings for 8.x so no UI is required. Will be removed in 9.x when proper UI us added. https://mcneel.myjetbrains.com/youtrack/issue/RH-78977 https://mcneel.myjetbrains.com/youtrack/issue/RH-28804 https://mcneel.myjetbrains.com/youtrack/issue/RH-48103
AcadExportWriteEmptyLayers23 ditto
DisableModelAndPageUnitsDifferDialog24 Advanced settings to re-enable the units helper dialogs. see https://mcneel.myjetbrains.com/youtrack/issue/RH-81439
DisablePageUnitsNotInchesOrMMDialog25 ditto
UseLegacyCurveJoiner26 6-May-2024 Dale Fugier, https://mcneel.myjetbrains.com/youtrack/issue/RH-81815
UseLegacyBrepCapper27 13-Jun-2024 Dale Fugier, https://mcneel.myjetbrains.com/youtrack/issue/RH-82566
HideFloatingWindowsOnDeactivate28 19-Sep-2024 Dale Fugier, https://mcneel.myjetbrains.com/youtrack/issue/RH-83845
See Also