TextFields Class |
Namespace: Rhino.Runtime
The TextFields type exposes the following members.
Name | Description | |
---|---|---|
Area(String) |
Returns the area value for a selected object id
| |
Area(String, String) |
Returns the area value for a selected object id in a specified unit system
| |
BlockAttributeText |
User text associated with a block
| |
BlockDescription |
Returns a block definition description
| |
BlockInstanceCount |
Returns the number of block instances found in the document
with the specified block definition name or the instance reference id.
| |
BlockInstanceName |
Returns the block definition name of a block instance
Use BlockName Instead
| |
BlockName |
Returns the block definition name of a block instance
| |
CurveLength(String) |
Get length of a curve given a string id
| |
CurveLength(String, String) |
Get length of a curve given a string id in a specified unit system.
UnitSystem enumeration as string
| |
Date |
Current date
| |
Date(String) |
Current date in a specified format
| |
Date(String, String) |
Current Date in a specific format and language
| |
DateModified |
Date the document was last edited
| |
DateModified(String) |
Date the document was last edited in a specified format
| |
DateModified(String, String) |
Date the document was last edited in a specific format and language in local time
| |
DetailScale |
Returns a detail views scale
| |
DocumentText |
Return document user string for a given key
| |
FileName |
Return full path to the document
| |
FileName(String) |
Return path to the document
| |
GetInstanceAttributeFields(InstanceDefinition) | ||
GetInstanceAttributeFields(String) |
Gets an array of block attribute definitions associated with a
TextObject.
| |
GetInstanceAttributeFields(TextObject) |
Gets an array of block attribute definitions associated with a
TextObject.
| |
LayerName |
Returns the name of a layer based on the layers guid
| |
LayoutUserText(String) |
Returns a value from the active layouts user text strings for the specified key.
| |
LayoutUserText(String, String) |
Returns user text value from a layout id Key
| |
ModelUnits | ||
Notes |
Notes for a RhinoDoc
| |
NumPages |
Number of layout pages in a document
| |
ObjectLayer |
Return an object's layer name
| |
ObjectName |
Returns an attached Text objects attribute name.
| |
ObjectName(String) |
Return an object's name
| |
ObjectPageName |
Returns the layout page name the object resides on
| |
ObjectPageNumber |
Returns the layout page number the object resides on
| |
PageHeight |
Return the current layout page height in the layout units
| |
PageName |
Return the current layout page name
| |
PageName(String) |
Return the page name for the specified View ID
| |
PageNumber |
Returns the current layouts page number
| |
PageWidth |
Return the current layout page width in the layout units
| |
PaperName |
Returns the layouts selected paper name
example Letter / A4 / A6
| |
PointCoordinate |
returns the location of a 3d point
| |
TryFormat |
Formats the contents of a text string with field expressions
and returns the result
| |
TryParse |
Evaluates the contents of a text string with field expressions
and returns the result
| |
UserText(String, String) |
User text associated with an object, block or layout
| |
UserText(String, String, String) |
User text associated with an object, block or layout
| |
UserText(String, String, String, String) |
User text associated with an object, block or layout
| |
Volume(String) |
Returns the volume for the selected object id
open objects return 0 volume
| |
Volume(String, String) |
Returns a volume;
if the opt param is a bool "true/false" or "1/0" then open objects are inspected or ignored.
if the opt param is a unit system as a string "millimeter" then the volume will be returned if the object is closed and in the specified unit system.
Open objects return 0
| |
Volume(String, String, String) |
Returns a volume from an object Id.
If allowOpenObjects = false objects which are open will return 0.0 as a volume.
|