Click or drag to resize

TextFields Methods

The TextFields type exposes the following members.

Methods
  NameDescription
Public methodStatic memberArea(String)
Returns the area value for a selected object id
Public methodStatic memberArea(String, String)
Returns the area value for a selected object id in a specified unit system
Public methodStatic memberBlockAttributeText
User text associated with a block
Public methodStatic memberBlockDescription
Returns a block definition description
Public methodStatic memberBlockInstanceCount
Returns the number of block instances found in the document with the specified block definition name or the instance reference id.
Public methodStatic memberBlockInstanceName
Returns the block definition name of a block instance Use BlockName Instead
Public methodStatic memberBlockName
Returns the block definition name of a block instance
Public methodStatic memberCurveLength(String)
Get length of a curve given a string id
Public methodStatic memberCurveLength(String, String)
Get length of a curve given a string id in a specified unit system. UnitSystem enumeration as string
Public methodStatic memberDate
Current date
Public methodStatic memberDate(String)
Current date in a specified format
Public methodStatic memberDate(String, String)
Current Date in a specific format and language
Public methodStatic memberDateModified
Date the document was last edited
Public methodStatic memberDateModified(String)
Date the document was last edited in a specified format
Public methodStatic memberDateModified(String, String)
Date the document was last edited in a specific format and language in local time
Public methodStatic memberDetailScale
Returns a detail views scale
Public methodStatic memberDocumentText
Return document user string for a given key
Public methodStatic memberFileName
Return full path to the document
Public methodStatic memberFileName(String)
Return path to the document
Public methodStatic memberGetInstanceAttributeFields(InstanceDefinition)
Public methodStatic memberGetInstanceAttributeFields(String)
Gets an array of block attribute definitions associated with a TextObject.
Public methodStatic memberGetInstanceAttributeFields(TextObject)
Gets an array of block attribute definitions associated with a TextObject.
Public methodStatic memberLayerName
Returns the name of a layer based on the layers guid
Public methodStatic memberLayoutUserText(String)
Returns a value from the active layouts user text strings for the specified key.
Public methodStatic memberLayoutUserText(String, String)
Returns user text value from a layout id Key
Public methodStatic memberModelUnits
Public methodStatic memberNotes
Notes for a RhinoDoc
Public methodStatic memberNumPages
Number of layout pages in a document
Public methodStatic memberObjectLayer
Return an object's layer name
Public methodStatic memberObjectName
Returns an attached Text objects attribute name.
Public methodStatic memberObjectName(String)
Return an object's name
Public methodStatic memberObjectPageName
Returns the layout page name the object resides on
Public methodStatic memberObjectPageNumber
Returns the layout page number the object resides on
Public methodStatic memberPageHeight
Return the current layout page height in the layout units
Public methodStatic memberPageName
Return the current layout page name
Public methodStatic memberPageName(String)
Return the page name for the specified View ID
Public methodStatic memberPageNumber
Returns the current layouts page number
Public methodStatic memberPageWidth
Return the current layout page width in the layout units
Public methodStatic memberPaperName
Returns the layouts selected paper name example Letter / A4 / A6
Public methodStatic memberPointCoordinate
returns the location of a 3d point
Public methodStatic memberTryFormat
Formats the contents of a text string with field expressions and returns the result
Public methodStatic memberTryParse
Evaluates the contents of a text string with field expressions and returns the result
Public methodStatic memberUserText(String, String)
User text associated with an object, block or layout
Public methodStatic memberUserText(String, String, String)
User text associated with an object, block or layout
Public methodStatic memberUserText(String, String, String, String)
User text associated with an object, block or layout
Public methodStatic memberVolume(String)
Returns the volume for the selected object id open objects return 0 volume
Public methodStatic memberVolume(String, String)
Returns a volume; if the opt param is a bool "true/false" or "1/0" then open objects are inspected or ignored. if the opt param is a unit system as a string "millimeter" then the volume will be returned if the object is closed and in the specified unit system. Open objects return 0
Public methodStatic memberVolume(String, String, String)
Returns a volume from an object Id. If allowOpenObjects = false objects which are open will return 0.0 as a volume.
Top
See Also