Click or drag to resize

Analytics Class

Provides tools for sending Google Analytics events using the Measurement Protocol. See https://developers.google.com/analytics/devguides/collection/protocol/v1/devguide#event for details.
Inheritance Hierarchy
SystemObject
  Rhino.RuntimeAnalytics

Namespace:  Rhino.Runtime
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Analytics

The Analytics type exposes the following members.

Constructors
  NameDescription
Public methodAnalytics(String, String)
Construct Analytics class
Public methodAnalytics(String, String, String, String, String)
Construct Analytics class
Top
Properties
  NameDescription
Public propertyAppInstallerId
App Installer Id. In Rhino, we use this to differentiate between different builds such as "WIP" and "Commercial". Maps to Google Analytics parameter 'aiid'
Public propertyAppName
Name of Application. For example, "Ocelot". Do not include version numbers. Maps to Google Analytics parameter 'an'
Public propertyAppPlatform
Platform application is running on. For example "Mac", "Windows". Again, don't include version numbers. Maps to Google Analytics parameter 'ai'
Public propertyAppVersion
Application version string. Maps to Google Analytics parameter 'av'
Public propertyGoogleAnalyticsTrackingID
Google Analytics Tracking ID
Public propertyStatic memberUsageStatisticsEnabled
Determine if user allows automatic data collection from Rhino
Public propertyStatic memberUserId
Returns a GUID that allows events to be aggregated by user. There is no way to determine who the end user is based on this GUID, unless the user tells you their ID. On Windows, this uses the registry to store the ID. On Mac, the Hardware UUID is used as the ID.
Top
Methods
  NameDescription
Public methodSend(NameValueCollection)
Advanced method for sending Google Analytics data. It is the caller's responsibility to make sure that all parameters passed will result in a valid Google Analytics hit. Failure to do so will result in Google Analytics ignoring your hit, and the caller will get no data. The Analytics class will populate data from the Application, the GoogleAnalyticsTrackingID, the User ID, and set the hit type "t" to "event". It also sets other information about the system.
Public methodSend(String)
Sends a Google Analytics event using the Measurement Protocol. See https://developers.google.com/analytics/devguides/collection/protocol/v1/devguide#event for details.
Public methodSend(String, String)
Sends a Google Analytics event using the Measurement Protocol. See https://developers.google.com/analytics/devguides/collection/protocol/v1/devguide#event for details.
Public methodSend(String, String, String)
Sends a Google Analytics event using the Measurement Protocol. See https://developers.google.com/analytics/devguides/collection/protocol/v1/devguide#event for details.
Public methodSend(String, String, String, UInt32)
Sends a Google Analytics event using the Measurement Protocol. See https://developers.google.com/analytics/devguides/collection/protocol/v1/devguide#event for details. This method is asyncrhonous and the return code is completely ignored. Validate the data you send
Top
See Also