Click or drag to resize

ViewCaptureWriter Class

Callback system used by SVG and PDF exporter to generate documents. Not intended for general SDK usage
Inheritance Hierarchy
SystemObject
  Rhino.RuntimeViewCaptureWriter

Namespace:  Rhino.Runtime
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class ViewCaptureWriter

The ViewCaptureWriter type exposes the following members.

Constructors
  NameDescription
Public methodViewCaptureWriter
Initializes a new instance of the ViewCaptureWriter class
Top
Properties
  NameDescription
Protected propertyDpi
Protected propertyPageSize
Top
Methods
  NameDescription
Public methodDraw
Protected methodDrawBitmap
Protected methodDrawCircle
Protected methodDrawGradientHatch
Protected methodDrawPath
Protected methodDrawRectangle
Protected methodDrawScreenText
Protected methodFillPolygon
Protected methodFlush
Protected methodPopClipPath
Protected methodPushClipPath(ViewCaptureWriterPathPoint)
Protected methodPushClipPath(RectangleF)
Protected methodSetClipPath
Protected methodSupportsArc
Top
See Also