Click or drag to resize

ZooClientParameters Class

ZooClientParameters is a read-only set of parameters that control the flow of licensing inside ZooClient. Because this class flows through a number of other classes, functions, and UI, it is read-only so that inadvertent changes are not made to the data as it propagates from the caller.
Inheritance Hierarchy
SystemObject
  Rhino.RuntimeZooClientParameters

Namespace:  Rhino.Runtime
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ZooClientParameters

The ZooClientParameters type exposes the following members.

Constructors
  NameDescription
Public methodZooClientParameters
ZooClientParameters Constructor
Top
Properties
  NameDescription
Public propertyCapabilities
LicenseCapabilities flags that set options for how licenses can be obtained for this product
Public propertyLicenseEntryTextMask
Text mask in the form @"RH4A-AAAA-AAAA-AAAA-AAAA-AAAA" that informs the user what numbers they are looking for
Public propertyLicenseGuid
Guid used by ZooClient to identify the license saved by ZooClient. This differs from ProductGuid because different versions of a plug-in with the same Plug-in ID may need different licenses.
Public propertyOnLeaseChanged
Delegate called by ZooClient when a cloud zoo lease is changed
Public propertyParentWindow
Parent window assigned to any licensing dialogs that appear. If null, the Rhino main window is used.
Public propertyProductBuildType
Product build type. Must be one of LicenseBuildType values.
Public propertyProductGuid
Guid used by ZooClient to identify the plug-in requesting a license from ZooClient. This Guid may be used by different versions of the plug-in. If different licenses are used by different versions of the plug-in, the plug-in must also specify a LicenseGuid.
Public propertyProductPath
Path to the application calling ZooClient
Public propertyProductTitle
Title of the product, "Rhinoceros 6" for example.
Public propertySelectedLicenseType
License type selected by default when user is prompted to enter a license key
Top
Methods
  NameDescription
Public methodVerifyLicenseKey
Called by GetLicense to ensure that the license key entered by the user is legitimate and can be used.
Public methodVerifyPreviousVersionLicense
When a caller calls GetLicense, ZooClient may call VerifyPreviousVersionLicense to ensure previousVersionLicense is legitimate and can be used to upgrade license.
Top
See Also