Click or drag to resize

AssemblyResolver Class

Assembly Resolver for the Rhino App Domain.
Inheritance Hierarchy
SystemObject
  Rhino.RuntimeAssemblyResolver

Namespace:  Rhino.Runtime
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class AssemblyResolver

The AssemblyResolver type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberCurrentDomainAssemblyResolve
Standard resolver function used by Rhino in execution context. This is added to the Current AssemblyResolve.
Public propertyStatic memberCurrentDomainReflectionOnlyAssemblyResolve
Standard resolver function used by Rhino in reflection-only context. This is added to the Current ReflectionOnlyAssemblyResolve.
Top
Methods
  NameDescription
Public methodStatic memberAddSearchFile
Register another file with the Assembly Resolver. File must be a .NET assembly, so it should probably be a dll, rhp or exe.
Public methodStatic memberAddSearchFolder
Register a custom folder with the Assembly Resolver. Folders will be searched recursively, so this could potentially be a very expensive operation. If at all possible, you should consider only registering individual files.
Top
See Also