Click or drag to resize

NamedParametersEventArgs Class

Dictionary style class used for named callbacks from C++ -> .NET
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Rhino.RuntimeNamedParametersEventArgs

Namespace:  Rhino.Runtime
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class NamedParametersEventArgs : EventArgs, 
	IDisposable

The NamedParametersEventArgs type exposes the following members.

Constructors
  NameDescription
Public methodNamedParametersEventArgs
Construct a new named parameter even args. You should dispose this class when you are done with it
Top
Methods
  NameDescription
Public methodDispose
Dispose native resources
Protected methodFinalize
Finalizer in case Dispose wasn't called
(Overrides ObjectFinalize.)
Public methodSet(String, Arc)
Set an arc for the specified key
Public methodSet(String, GeometryBase)
Set geometry for a given key name
Public methodSet(String, Line)
Set a line for the specified key
Public methodSet(String, MeshingParameters)
Set an MeshingParameters for the specified key
Public methodSet(String, Plane)
Set a plane for the specified key
Public methodSet(String, Point3d)
Set a Point3d value for a given key name
Public methodSet(String, Point3d)
Set a point array for the specified key
Public methodSet(String, Vector3d)
Set a Vector3d value for a given key name
Public methodSet(String, Boolean)
Set a bool value for a given key name
Public methodSet(String, IEnumerableObjRef)
Set a list of ObjRef instances as a value for a given key name
Public methodSet(String, IEnumerableGeometryBase)
Set a list of geometry for a given key name
Public methodSet(String, IEnumerableGuid)
Set a list of UUIDs as a value for a given key name
Public methodSet(String, IEnumerableString)
Set a list of strings as a value for a given key name
Public methodSet(String, IEnumerableUInt32)
Set a list of uint as a value for a given key name
Public methodSet(String, Double)
Set a double value for a given key name
Public methodSet(String, Color)
Set a Color value for a given key name
Public methodSet(String, Point)
Set a Point value for a given key name
Public methodSet(String, Guid)
Set a Color value for a given key name
Public methodSet(String, Int32)
Set an int value for a given key name
Public methodSet(String, String)
Set a string value for a given key name
Public methodSet(String, UInt32)
Set an unsigned int for a given key name
Public methodSetWindowHandle
Set a HWND on Windows or NSView* on Mac
Public methodSetWindowImageHandle
Set a HWND on Windows or NSView* on Mac
Public methodTryGetArc
Get a arc for the specified key
Public methodTryGetBool
Try to get a bool value for a given key name
Public methodTryGetColor
Try to get a Color value for a given key name
Public methodTryGetDouble
Try to get a double value for a given key name
Public methodTryGetGeometry
Public methodTryGetGuid
Try to get a Color value for a given key name
Public methodTryGetGuids
Try to get a UUID array value for a given key name
Public methodTryGetInt
Try to get an int value for a given key name
Public methodTryGetLine
Get a line for the specified key
Public methodTryGetMeshParameters
Get an MeshingParameters for the specified key
Public methodTryGetObjRefs
Try to get an array of ObjRef instances for a given key name
Public methodTryGetPlane
Get a plane for the specified key
Public methodTryGetPoint
Try to get a Point3d value for a given key name
Public methodTryGetPoint2i
Try to get a Point value for a given key name
Public methodTryGetPoints
Gets a point array for the specified key
Public methodTryGetRhinoObjects
Get array of RhinoObject for the specified key
Public methodTryGetString
Try to get a string value for a given key name
Public methodTryGetStrings
Try to get a string array for a given key name
Public methodTryGetUints
Try to get a uint array value for a given key name
Public methodTryGetUnmangedPointer
Gets a HWND on Windows or NSVIew* on Mac
Public methodTryGetUnsignedInt
Try to get an unsigned int for a given key name
Public methodTryGetVector
Try to get a Vector3d value for a given key name
Public methodTryGetViewport
Try to get a viewport for a given key name
Public methodTryGetWindowHandle
Gets a HWND on Windows or NSVIew* on Mac
Public methodTryGetWindowImageHandle
Gets a HWND on Windows or NSVIew* on Mac
Top
See Also