Click or drag to resize

Skin Class

Represents a customized environment that changes the appearance of Rhino.

Skin DLLs must contain a single class that derives from the Skin class.

Inheritance Hierarchy
SystemObject
  Rhino.RuntimeSkin

Namespace:  Rhino.Runtime
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class Skin

The Skin type exposes the following members.

Constructors
  NameDescription
Protected methodSkin
Initializes a new instance of the Skin class.
Top
Properties
  NameDescription
Public propertyStatic memberActiveSkin
Any time Rhino is running there is at most one skin being used (and possibly no skin). If a RhinoCommon based Skin class is being used, use ActiveSkin to get at the instance of this Skin class. May return null if no Skin is being used or if the skin is not a RhinoCommon based skin.
Protected propertyApplicationName
If you want to provide a custom name for your skin.
Protected propertyMainRhinoIcon
If you want to provide a custom icon for your skin.
Public propertySettings
Gets access to the skin persistent settings.
Top
Methods
  NameDescription
Protected methodHideSplash
Is called when the splash screen should be hidden.
Protected methodOnBeginLoadAtStartPlugIns
Is called when the first plug-in that loads at start-up is going to be loaded.
Protected methodOnBeginLoadPlugIn
Is called when a specific plug-in is going to be loaded.
Protected methodOnBuiltInCommandsRegistered
Is called when built-in commands are registered.
Protected methodOnEndLoadAtStartPlugIns
Is called after all of the load at start plug-ins have been loaded.
Protected methodOnEndLoadPlugIn
Is called after each plug-in has been loaded.
Protected methodOnLicenseCheckCompleted
Is called when the license check is completed.
Protected methodOnMainFrameWindowCreated
Is called when the main frame window is created.
Protected methodShowHelp
Called when the "help" splash screen should be shown. Default implementation just calls ShowSplash()
Protected methodShowSplash
Is called when the splash screen should be shown.
Top
See Also