Click or drag to resize

Environment Class

Represents an environment.
Inheritance Hierarchy

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Environment : CommonObject

The Environment type exposes the following members.

Constructors
  NameDescription
Public methodEnvironment
Initializes a new environment.
Top
Properties
  NameDescription
Public propertyBackgroundColor
The background color.
Public propertyBackgroundImage
The background image texture.
Public propertyBackgroundProjection
The background projection.
Top
Methods
  NameDescription
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Top
See Also