Click or drag to resize

ModelComponent Class

Base class for all components in a model (document) and manages the index, id and other information common to this type of objects.

This class parallels the C++ ON_ModelComponent.

Inheritance Hierarchy
SystemObject
  Rhino.RuntimeCommonObject
    Rhino.DocObjectsModelComponent
      More...

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class ModelComponent : CommonObject

The ModelComponent type exposes the following members.

Properties
  NameDescription
Public propertyComponentStatus
Gets or sets the component status of the model component.
Public propertyComponentType
Gets the ModelComponentType for this object. Useful in switch statements.
Public propertyDeletedName
Gets the name of a component that is deleted.
Public propertyHasId
Returns a value indicating whether the component has an ID.
Public propertyHasIndex
Returns a value indicating whether the component has an Index.
Public propertyHasName
Returns a value indicating whether the component has a Name.
Public propertyId
Gets or sets the ID of the current instance.
Public propertyIdIsLocked
Returns a value indicating whether the component ID is already locked.
Public propertyIndex
Gets or sets the model component index attribute.
Public propertyIndexIsLocked
Returns a value indicating whether the component Index is already locked.
Public propertyInstanceDefinitionModelSerialNumber
When a component is in a model as part of the information required for a linked instance definition, this value identifies the linked instance definition reference model.
Public propertyIsComponentStatusLocked
The component status itself can be locked. This returns an indication.
Public propertyIsDeleted
true if the component is deleted. Deleted components are kept by the document for undo purposes.
Public propertyIsReference
Gets a value indicting whether this component is a referenced component. Referenced components are part of referenced documents.
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
  • ON_DimStyle::DefaultMillimeterArchitecture
Public propertyModelSerialNumber
A value identifying the model that manages this component.
Public propertyCode exampleName
Gets or sets the name
Public propertyNameIsLocked
Returns a value indicating whether the component Name is already locked.
Public propertyStatic memberNamePathSeparator
Returns the string "::". This is the string Rhino uses in layer full path names to separate the names of individual layers.
Public propertyReferenceModelSerialNumber
When a component is in a model for reference, this value identifies the reference model.
Top
Methods
  NameDescription
Public methodClearId
Resets the HasId property of the model component to false, if possible.
Public methodClearIndex
Resets the HasIndex property of the model component to false, if possible.
Public methodClearName
Resets the HasName property of the model component to false, if possible.
Public methodDataCRC
Increments the Cyclic Redundancy Check value by this instance.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodStatic memberIsValidComponentName
Tests for a valid model component name.
Public methodLockId
Locks the component Id property.
Public methodLockIndex
Locks the component Index property.
Public methodLockName
Locks the component Name property.
Public methodStatic memberModelComponentTypeIgnoresCase
Informs the developer if a particular model component type will require case-ignoring searching within a document. This is currently true with groups; false otherwise.
Public methodStatic memberModelComponentTypeIncludesParent
Informs the developer if a particular model component type will include the hash of the parent.
Public methodStatic memberModelComponentTypeRequiresUniqueName
Informs the developer if a particular model component type will require uniqueness within a document. This is currently true with render materials and model geometry; false otherwise.
Public methodToString
Returns the name of the model component type, and then its name and index.
(Overrides ObjectToString.)
Top
See Also
Inheritance Hierarchy
SystemObject
  Rhino.RuntimeCommonObject
    Rhino.DocObjectsModelComponent
      Rhino.DocObjectsBitmapEntry
      Rhino.DocObjectsDimensionStyle
      Rhino.DocObjectsGroup
      Rhino.DocObjectsHatchPattern
      Rhino.DocObjectsLayer
      Rhino.DocObjectsLinetype
      Rhino.DocObjectsMaterial
      Rhino.DocObjectsRhinoObject
      Rhino.DocObjectsSectionStyle
      Rhino.FileIOFile3dmEmbeddedFile
      Rhino.FileIOFile3dmObject
      Rhino.FileIOFile3dmRenderContent
      Rhino.GeometryInstanceDefinitionGeometry
      Rhino.RenderTextureMapping