Click or drag to resize

BitmapEntry Class

Rhino.DocObjects.Tables.BitmapTable entry
Inheritance Hierarchy

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public sealed class BitmapEntry : ModelComponent

The BitmapEntry type exposes the following members.

Properties
  NameDescription
Public propertyComponentType
Returns Image.
(Overrides ModelComponentComponentType.)
Public propertyFileName
The name of this bitmap.
Public propertyIsReference
Gets a value indicting whether this bitmap is a referenced bitmap. Referenced bitmaps are part of referenced documents.
(Overrides ModelComponentIsReference.)
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Top
Methods
  NameDescription
Public methodSave
Top
See Also