RhinoCommon API
RhinoCommon API
Namespaces
Rhino.DocObjects
ModelComponent Class
ModelComponent Methods
ClearId Method
ClearIndex Method
ClearName Method
DataCRC Method
IsValidComponentName Method
LockId Method
LockIndex Method
LockName Method
ModelComponentTypeIgnoresCase Method
ModelComponentTypeIncludesParent Method
ModelComponentTypeRequiresUniqueName Method
ToString Method
ModelComponent
ClearId Method
Resets the HasId property of the model component to false, if possible.
Namespace:
Rhino.DocObjects
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
6.0
Syntax
C#
VB
Copy
public
void
ClearId
()
Public
Sub
ClearId
Exceptions
Exception
Condition
InvalidOperationException
If the ID is locked.
See Also
Reference
ModelComponent Class
Rhino.DocObjects Namespace
Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com