Click or drag to resize

ModelComponentModelComponentTypeRequiresUniqueName Method

Informs the developer if a particular model component type will require uniqueness within a document. This is currently true with render materials and model geometry; false otherwise.

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static bool ModelComponentTypeRequiresUniqueName(
	ModelComponentType type
)

Parameters

type
Type: Rhino.DocObjectsModelComponentType
The type to check.

Return Value

Type: Boolean
true with render materials and model geometry; false otherwise.
See Also