Click or drag to resize

ModelComponent Methods

The ModelComponent type exposes the following members.

Methods
  NameDescription
Public methodClearId
Resets the HasId property of the model component to false, if possible.
Public methodClearIndex
Resets the HasIndex property of the model component to false, if possible.
Public methodClearName
Resets the HasName property of the model component to false, if possible.
Public methodDataCRC
Increments the Cyclic Redundancy Check value by this instance.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodStatic memberIsValidComponentName
Tests for a valid model component name.
Public methodLockId
Locks the component Id property.
Public methodLockIndex
Locks the component Index property.
Public methodLockName
Locks the component Name property.
Public methodStatic memberModelComponentTypeIgnoresCase
Informs the developer if a particular model component type will require case-ignoring searching within a document. This is currently true with groups; false otherwise.
Public methodStatic memberModelComponentTypeIncludesParent
Informs the developer if a particular model component type will include the hash of the parent.
Public methodStatic memberModelComponentTypeRequiresUniqueName
Informs the developer if a particular model component type will require uniqueness within a document. This is currently true with render materials and model geometry; false otherwise.
Public methodToString
Returns the name of the model component type, and then its name and index.
(Overrides ObjectToString.)
Top
See Also