Click or drag to resize

Material Class

[Missing <summary> documentation for "T:Rhino.DocObjects.Material"]

Inheritance Hierarchy

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public sealed class Material : ModelComponent

The Material type exposes the following members.

Constructors
  NameDescription
Public methodMaterial
Initializes a new instance of the Material class
Public methodMaterial(Material)
Initializes a new instance of the Material class
Top
Properties
  NameDescription
Public propertyAlphaTransparency
Public propertyAmbientColor
Public propertyComponentType
Returns RenderMaterial.
(Overrides ModelComponentComponentType.)
Public propertyStatic memberDefaultMaterial
Public propertyDiffuseColor
Public propertyDisableLighting
Public propertyEmissionColor
Public propertyFresnelIndexOfRefraction
Gets or sets the Fresnel index of refraction of the material, default is 1.56
Public propertyFresnelReflections
Gets or sets if Fresnel reflections are used.
Public propertyIndexOfRefraction
Gets or sets the index of refraction of the material, generally >= 1.0 (speed of light in vacuum)/(speed of light in material)
Public propertyIsDefaultMaterial
By default Rhino layers and objects are assigned the default rendering material.
Public propertyIsDeleted
Deleted materials are kept in the runtime material table so that undo will work with materials. Call IsDeleted to determine to determine if a material is deleted.
(Overrides ModelComponentIsDeleted.)
Public propertyIsDocumentControlled
If true this object may not be modified. Any properties or functions that attempt to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Overrides CommonObjectIsDocumentControlled.)
Public propertyIsPhysicallyBased
Public propertyIsReference
Rhino allows multiple files to be viewed simultaneously. Materials in the document are "normal" or "reference". Reference materials are not saved.
(Overrides ModelComponentIsReference.)
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyStatic memberMaxShine
Public propertyName (Overrides ModelComponentName.)
Public propertyPhysicallyBased
Public propertyPreviewColor
Very simple preview color function for GUIs.
Public propertyRDKMaterialID
Gets the RDK material ID.
Public propertyReflectionColor
Public propertyReflectionGlossiness
Gets or sets the reflection glossiness.
Public propertyReflectivity
Gets or sets how reflective a material is, 0f is no reflection 1f is 100% reflective.
Public propertyRefractionGlossiness
Gets or sets the refraction glossiness.
Public propertyRenderMaterial
Get the RenderMaterial related to this Material. Will create a new RenderMaterial if none exists. This can happen for older documents.
Public propertyRenderMaterialInstanceId
Public propertyRenderPlugInId
The Id of the RenderPlugIn that is associated with this material.
Public propertyShine
Gets or sets the shine factor of the material.
Public propertySpecularColor
Public propertyTransparency
Gets or sets the transparency of the material (0.0 = opaque to 1.0 = transparent)
Public propertyTransparentColor
Public propertyUseCount
Number of objects and layers that use this material.
Public propertyUserStringCount
Top
Methods
  NameDescription
Public methodClearMaterialChannels
Removes all material channels
Public methodCommitChanges
Public methodCopyFrom
Public methodDefault
Set material to default settings.
Public methodGetBitmapTexture
Public methodGetBumpTexture
Gets the bump texture of this material.
Public methodGetEnvironmentTexture
Public methodGetTexture
Get the texture that corresponds with the specified texture type for this material.
Public methodGetTextures
Get array of textures that this material uses
Public methodGetTransparencyTexture
Public methodGetUserString
Gets a user string.
Public methodGetUserStrings
Gets an independent copy of the collection of (user text key, user text value) pairs attached to this object.
Public methodMaterialChannelIdFromIndex
Finds id of the material channel at given index.
Public methodMaterialChannelIndexFromId
Finds index of the material channel that refers to a material channel with the given id. Optionally adds channel if one is not found.
Public methodSetBitmapTexture(String)
Public methodSetBitmapTexture(Texture)
Public methodSetBumpTexture(String)
Public methodSetBumpTexture(Texture)
Public methodSetEnvironmentTexture(String)
Public methodSetEnvironmentTexture(Texture)
Public methodSetTexture
Set the texture that corresponds with the specified texture type for this material.
Public methodSetTransparencyTexture(String)
Public methodSetTransparencyTexture(Texture)
Public methodSetUserString
Attach a user string (key,value combination) to this geometry.
Public methodToPhysicallyBased
Top
See Also