Click or drag to resize

Material Methods

The Material type exposes the following members.

Methods
  NameDescription
Public methodClearMaterialChannels
Removes all material channels
Public methodCommitChanges
Public methodCopyFrom
Public methodDefault
Set material to default settings.
Public methodGetBitmapTexture
Public methodGetBumpTexture
Gets the bump texture of this material.
Public methodGetEnvironmentTexture
Public methodGetTexture
Get the texture that corresponds with the specified texture type for this material.
Public methodGetTextures
Get array of textures that this material uses
Public methodGetTransparencyTexture
Public methodGetUserString
Gets a user string.
Public methodGetUserStrings
Gets an independent copy of the collection of (user text key, user text value) pairs attached to this object.
Public methodMaterialChannelIdFromIndex
Finds id of the material channel at given index.
Public methodMaterialChannelIndexFromId
Finds index of the material channel that refers to a material channel with the given id. Optionally adds channel if one is not found.
Public methodSetBitmapTexture(String)
Public methodSetBitmapTexture(Texture)
Public methodSetBumpTexture(String)
Public methodSetBumpTexture(Texture)
Public methodSetEnvironmentTexture(String)
Public methodSetEnvironmentTexture(Texture)
Public methodSetTexture
Set the texture that corresponds with the specified texture type for this material.
Public methodSetTransparencyTexture(String)
Public methodSetTransparencyTexture(Texture)
Public methodSetUserString
Attach a user string (key,value combination) to this geometry.
Public methodToPhysicallyBased
Top
See Also