Click or drag to resize

ModelComponent Properties

The ModelComponent type exposes the following members.

Properties
  NameDescription
Public propertyComponentStatus
Gets or sets the component status of the model component.
Public propertyComponentType
Gets the ModelComponentType for this object. Useful in switch statements.
Public propertyDeletedName
Gets the name of a component that is deleted.
Public propertyHasId
Returns a value indicating whether the component has an ID.
Public propertyHasIndex
Returns a value indicating whether the component has an Index.
Public propertyHasName
Returns a value indicating whether the component has a Name.
Public propertyId
Gets or sets the ID of the current instance.
Public propertyIdIsLocked
Returns a value indicating whether the component ID is already locked.
Public propertyIndex
Gets or sets the model component index attribute.
Public propertyIndexIsLocked
Returns a value indicating whether the component Index is already locked.
Public propertyInstanceDefinitionModelSerialNumber
When a component is in a model as part of the information required for a linked instance definition, this value identifies the linked instance definition reference model.
Public propertyIsComponentStatusLocked
The component status itself can be locked. This returns an indication.
Public propertyIsDeleted
true if the component is deleted. Deleted components are kept by the document for undo purposes.
Public propertyIsReference
Gets a value indicting whether this component is a referenced component. Referenced components are part of referenced documents.
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
  • ON_DimStyle::DefaultMillimeterArchitecture
Public propertyModelSerialNumber
A value identifying the model that manages this component.
Public propertyCode exampleName
Gets or sets the name
Public propertyNameIsLocked
Returns a value indicating whether the component Name is already locked.
Public propertyStatic memberNamePathSeparator
Returns the string "::". This is the string Rhino uses in layer full path names to separate the names of individual layers.
Public propertyReferenceModelSerialNumber
When a component is in a model for reference, this value identifies the reference model.
Top
See Also