Click or drag to resize

File3dmObject Class

Used to store geometry table object definition and attributes in a File3dm.
Inheritance Hierarchy

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class File3dmObject : ModelComponent, 
	IEquatable<File3dmObject>

The File3dmObject type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets the attributes that are linked with this document object.
Public propertyComponentType
Returns ModelGeometry.
(Overrides ModelComponentComponentType.)
Public propertyGeometry
Gets the geometry that is linked with this document object.
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyName
Gets or sets the Name of the object. Equivalent to this.Attributes.Name.
(Overrides ModelComponentName.)
Top
Methods
  NameDescription
Public methodEquals(File3dmObject)
Verified that two File3dmObject items refer to the same object in a document.
Public methodEquals(Object)
Verified that two objects refer to the same object in a document.
(Overrides ObjectEquals(Object).)
Public methodGetHashCode
Provides an hash code for this item.
(Overrides ObjectGetHashCode.)
Public methodGetTextureMapping
Gets the texture mapping from the File3dmObject object.
Public methodTryReadUserData
Attempts to read a Rhino plug-in's custom userdata from the File3dmObject object.
Top
See Also