File3dmObject Properties |
The File3dmObject type exposes the following members.
Name | Description | |
---|---|---|
Attributes |
Gets the attributes that are linked with this document object.
ComponentType |
Returns ModelGeometry.
Disposed |
Indicates if this object has been disposed or the
Geometry |
Gets the geometry that is linked with this document object.
InstanceDefinitionModelSerialNumber |
When a component is in a model as part of the information required for a linked instance definition,
IsDeleted |
true if the component is deleted.
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
IsReference |
Gets a value indicting whether this component is a referenced component.
| |
Name |
Gets or sets the Name of the object. Equivalent to this.Attributes.Name.
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user