HatchPattern Class |
[Missing <summary> documentation for "T:Rhino.DocObjects.HatchPattern"]
Namespace: Rhino.DocObjects
The HatchPattern type exposes the following members.
Name | Description | |
---|---|---|
![]() | HatchPattern | Initializes a new instance of the HatchPattern class |
Name | Description | |
---|---|---|
![]() | ComponentStatus |
Gets or sets the component status of the model component.
(Inherited from ModelComponent.) |
![]() | ComponentType |
Returns HatchPattern.
(Overrides ModelComponentComponentType.) |
![]() | DeletedName |
Gets the name of a component that is deleted.
(Inherited from ModelComponent.) |
![]() | Description |
Gets and sets a short description of the pattern.
|
![]() | Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) |
![]() | FillType |
Gets the pattern's fill type.
|
![]() | HasId |
Returns a value indicating whether the component has an ID.
(Inherited from ModelComponent.) |
![]() | HasIndex |
Returns a value indicating whether the component has an Index.
(Inherited from ModelComponent.) |
![]() | HasName |
Returns a value indicating whether the component has a Name.
(Inherited from ModelComponent.) |
![]() | HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) |
![]() | HatchLineCount |
Get the number of HatchLines in the pattern.
|
![]() | HatchLines |
Gets all the hatch lines.
|
![]() | Id |
Gets or sets the ID of the current instance.
(Inherited from ModelComponent.) |
![]() | IdIsLocked |
Returns a value indicating whether the component ID is already locked.
(Inherited from ModelComponent.) |
![]() | Index |
Index in the hatch pattern table for this pattern. -1 if not in the table.
(Overrides ModelComponentIndex.) |
![]() | IndexIsLocked |
Returns a value indicating whether the component Index is already locked.
(Inherited from ModelComponent.) |
![]() | InstanceDefinitionModelSerialNumber |
When a component is in a model as part of the information required for a linked instance definition,
this value identifies the linked instance definition reference model.
(Inherited from ModelComponent.) |
![]() | IsComponentStatusLocked |
The component status itself can be locked. This returns an indication.
(Inherited from ModelComponent.) |
![]() | IsDeleted |
Deleted hatch patterns are kept in the runtime hatch pattern table so that undo
will work with hatch patterns. Call IsDeleted to determine to determine if
a hatch pattern is deleted.
(Overrides ModelComponentIsDeleted.) |
![]() | IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from CommonObject.) |
![]() | IsReference |
Rhino allows multiple files to be viewed simultaneously. Hatch patterns in the
document are "normal" or "reference". Reference hatch patterns are not saved.
(Overrides ModelComponentIsReference.) |
![]() | IsSystemComponent |
True if this model component is a system constant.
(Inherited from ModelComponent.)An incomplete list of system constant model components is below:
|
![]() | IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) |
![]() | ModelSerialNumber |
A value identifying the model that manages this component.
(Inherited from ModelComponent.) |
![]() ![]() | Name |
Gets or sets the name
(Inherited from ModelComponent.) |
![]() | NameIsLocked |
Returns a value indicating whether the component Name is already locked.
(Inherited from ModelComponent.) |
![]() | ReferenceModelSerialNumber |
When a component is in a model for reference, this value identifies the reference model.
(Inherited from ModelComponent.) |
![]() | UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) |
![]() | UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use shareable set of information.
(Inherited from CommonObject.) |
![]() | UserStringCount |
Gets the amount of user strings.
|
Name | Description | |
---|---|---|
![]() | AddHatchLine |
Add a HatchLine to the pattern.
|
![]() | ClearId |
Resets the HasId property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearIndex |
Resets the HasIndex property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearName |
Resets the HasName property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | CreatePreviewGeometry |
Creates preview line segments of the hatch pattern.
|
![]() | DataCRC |
Increments the Cyclic Redundancy Check value by this instance.
(Inherited from ModelComponent.) |
![]() | DeleteAllUserStrings | |
![]() | DeleteUserString | |
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) |
![]() | EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | GetUserString |
Gets user string from this geometry.
|
![]() | GetUserStrings |
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
|
![]() | HatchLineAt |
Gets a HatchLine at an index.
|
![]() | IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) |
![]() | LockId |
Locks the component Id property.
(Inherited from ModelComponent.) |
![]() | LockIndex |
Locks the component Index property.
(Inherited from ModelComponent.) |
![]() | LockName |
Locks the component Name property.
(Inherited from ModelComponent.) |
![]() ![]() | ReadFromFile |
Reads hatch pattern definitions from a file.
|
![]() | RemoveAllHatchLines |
Remove all of the hatch line from the pattern.
|
![]() | RemoveHatchLine |
Remove a hatch line from the pattern.
|
![]() | SetHatchLines |
Set all of the hatch lines at once. Existing hatch lines are deleted.
|
![]() | SetUserString |
Attach a user string (key,value combination) to this geometry.
|
![]() | ToJSON |
Create a JSON string representation of this object
(Inherited from CommonObject.) |
![]() | ToString |
Returns the name of the model component type, and then its name and index.
(Inherited from ModelComponent.) |