HatchPattern Methods |
The HatchPattern type exposes the following members.
Name | Description | |
---|---|---|
![]() | AddHatchLine |
Add a HatchLine to the pattern.
|
![]() | ClearId |
Resets the HasId property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearIndex |
Resets the HasIndex property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearName |
Resets the HasName property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | CreatePreviewGeometry |
Creates preview line segments of the hatch pattern.
|
![]() | DataCRC |
Increments the Cyclic Redundancy Check value by this instance.
(Inherited from ModelComponent.) |
![]() | DeleteAllUserStrings | |
![]() | DeleteUserString | |
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) |
![]() | EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | GetUserString |
Gets user string from this geometry.
|
![]() | GetUserStrings |
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
|
![]() | HatchLineAt |
Gets a HatchLine at an index.
|
![]() | IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) |
![]() | LockId |
Locks the component Id property.
(Inherited from ModelComponent.) |
![]() | LockIndex |
Locks the component Index property.
(Inherited from ModelComponent.) |
![]() | LockName |
Locks the component Name property.
(Inherited from ModelComponent.) |
![]() ![]() | ReadFromFile |
Reads hatch pattern definitions from a file.
|
![]() | RemoveAllHatchLines |
Remove all of the hatch line from the pattern.
|
![]() | RemoveHatchLine |
Remove a hatch line from the pattern.
|
![]() | SetHatchLines |
Set all of the hatch lines at once. Existing hatch lines are deleted.
|
![]() | SetUserString |
Attach a user string (key,value combination) to this geometry.
|
![]() | ToJSON |
Create a JSON string representation of this object
(Inherited from CommonObject.) |
![]() | ToString |
Returns the name of the model component type, and then its name and index.
(Inherited from ModelComponent.) |