HatchPattern Properties |
The HatchPattern type exposes the following members.
Name | Description | |
---|---|---|
![]() | ComponentStatus |
Gets or sets the component status of the model component.
(Inherited from ModelComponent.) |
![]() | ComponentType |
Returns HatchPattern.
(Overrides ModelComponent.ComponentType.) |
![]() | DeletedName |
Gets the name of a component that is deleted.
(Inherited from ModelComponent.) |
![]() | Description |
Gets and sets a short description of the pattern.
|
![]() | Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) |
![]() | FillType |
Gets the pattern's fill type.
|
![]() | HasId |
Returns a value indicating whether the component has an ID.
(Inherited from ModelComponent.) |
![]() | HasIndex |
Returns a value indicating whether the component has an Index.
(Inherited from ModelComponent.) |
![]() | HasName |
Returns a value indicating whether the component has a Name.
(Inherited from ModelComponent.) |
![]() | HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) |
![]() | HatchLineCount |
Get the number of HatchLines in the pattern.
|
![]() | HatchLines |
Gets all the hatch lines.
|
![]() | Id |
Gets or sets the ID of the current instance.
(Inherited from ModelComponent.) |
![]() | IdIsLocked |
Returns a value indicating whether the component ID is already locked.
(Inherited from ModelComponent.) |
![]() | Index |
Index in the hatch pattern table for this pattern. -1 if not in the table.
(Overrides ModelComponent.Index.) |
![]() | IndexIsLocked |
Returns a value indicating whether the component Index is already locked.
(Inherited from ModelComponent.) |
![]() | InstanceDefinitionModelSerialNumber |
When a component is in a model as part of the information required for a linked instance definition,
this value identifies the linked instance definition reference model.
(Inherited from ModelComponent.) |
![]() | InUse |
Returns true if the hatch pattern is in use by a Rhino object,
a layer, an instance definition, or a section style.
|
![]() | IsComponentStatusLocked |
The component status itself can be locked. This returns an indication.
(Inherited from ModelComponent.) |
![]() | IsDeleted |
Deleted hatch patterns are kept in the runtime hatch pattern table so that undo
will work with hatch patterns. Call IsDeleted to determine to determine if
a hatch pattern is deleted.
(Overrides ModelComponent.IsDeleted.) |
![]() | IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from CommonObject.) |
![]() | IsReference |
Rhino allows multiple files to be viewed simultaneously. Hatch patterns in the
document are "normal" or "reference". Reference hatch patterns are not saved.
(Overrides ModelComponent.IsReference.) |
![]() | IsSystemComponent |
True if this model component is a system constant.
(Inherited from ModelComponent.)An incomplete list of system constant model components is below:
|
![]() | IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) |
![]() | ModelSerialNumber |
A value identifying the model that manages this component.
(Inherited from ModelComponent.) |
![]() ![]() | Name |
Gets or sets the name
(Inherited from ModelComponent.) |
![]() | NameIsLocked |
Returns a value indicating whether the component Name is already locked.
(Inherited from ModelComponent.) |
![]() | ReferenceModelSerialNumber |
When a component is in a model for reference, this value identifies the reference model.
(Inherited from ModelComponent.) |
![]() | UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) |
![]() | UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use shareable set of information.
(Inherited from CommonObject.) |
![]() | UserStringCount |
Gets the amount of user strings.
|