TextureMapping Class |
Namespace: Rhino.Render
The TextureMapping type exposes the following members.
Name | Description | |
---|---|---|
![]() | ComponentStatus |
Gets or sets the component status of the model component.
(Inherited from ModelComponent.) |
![]() | ComponentType |
Returns TextureMapping.
(Overrides ModelComponentComponentType.) |
![]() | DeletedName |
Gets the name of a component that is deleted.
(Inherited from ModelComponent.) |
![]() | Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) |
![]() | HasId |
Returns a value indicating whether the component has an ID.
(Inherited from ModelComponent.) |
![]() | HasIndex |
Returns a value indicating whether the component has an Index.
(Inherited from ModelComponent.) |
![]() | HasName |
Returns a value indicating whether the component has a Name.
(Inherited from ModelComponent.) |
![]() | HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) |
![]() | Id |
The unique Id for this texture mapping object.
(Overrides ModelComponentId.) |
![]() | IdIsLocked |
Returns a value indicating whether the component ID is already locked.
(Inherited from ModelComponent.) |
![]() | Index |
Gets or sets the model component index attribute.
(Inherited from ModelComponent.) |
![]() | IndexIsLocked |
Returns a value indicating whether the component Index is already locked.
(Inherited from ModelComponent.) |
![]() | InstanceDefinitionModelSerialNumber |
When a component is in a model as part of the information required for a linked instance definition,
this value identifies the linked instance definition reference model.
(Inherited from ModelComponent.) |
![]() | IsComponentStatusLocked |
The component status itself can be locked. This returns an indication.
(Inherited from ModelComponent.) |
![]() | IsDeleted |
true if the component is deleted.
Deleted components are kept by the document for undo purposes.
(Inherited from ModelComponent.) |
![]() | IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from CommonObject.) |
![]() | IsReference |
Gets a value indicting whether this component is a referenced component.
Referenced components are part of referenced documents.
(Inherited from ModelComponent.) |
![]() | IsSystemComponent |
True if this model component is a system constant.
(Inherited from ModelComponent.)An incomplete list of system constant model components is below:
|
![]() | IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) |
![]() | MappingType |
Texture mapping type associated with this Mapping object.
|
![]() | ModelSerialNumber |
A value identifying the model that manages this component.
(Inherited from ModelComponent.) |
![]() ![]() | Name |
Gets or sets the name
(Inherited from ModelComponent.) |
![]() | NameIsLocked |
Returns a value indicating whether the component Name is already locked.
(Inherited from ModelComponent.) |
![]() | NormalTransform |
For primitive based mappings, these transformations are used to map
the world coordinate (x,y,z) point P and surface normal N before it is
projected to the normalized mapping primitive. The surface normal
transformation, m_Nxyz, is always calculated from m_Pxyz. It is a
runtime setting that is not saved in 3dm files. If m_type is
srfp_mapping, then m_Pxyz and m_Nxyz are ignored.
|
![]() | PrimativeTransform | Obsolete.
For primitive based mappings, these transformations are used to map
the world coordinate (x,y,z) point P and surface normal N before it is
projected to the normalized mapping primitive. The surface normal
transformation, m_Nxyz, is always calculated from m_Pxyz. It is a
runtime setting that is not saved in 3dm files. If m_type is
srfp_mapping, then m_Pxyz and m_Nxyz are ignored.
|
![]() | PrimitiveTransform |
For primitive based mappings, these transformations are used to map
the world coordinate (x,y,z) point P and surface normal N before it is
projected to the normalized mapping primitive. The surface normal
transformation, m_Nxyz, is always calculated from m_Pxyz. It is a
runtime setting that is not saved in 3dm files. If m_type is
srfp_mapping, then m_Pxyz and m_Nxyz are ignored.
|
![]() | ReferenceModelSerialNumber |
When a component is in a model for reference, this value identifies the reference model.
(Inherited from ModelComponent.) |
![]() | UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) |
![]() | UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use shareable set of information.
(Inherited from CommonObject.) |
![]() | UvwTransform |
Transform applied to mapping coordinate (u,v,w) to convert it into a
texture coordinate.
|
Name | Description | |
---|---|---|
![]() | ClearId |
Resets the HasId property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearIndex |
Resets the HasIndex property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearName |
Resets the HasName property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() ![]() | CreateBoxMapping | Create a box projection texture mapping. |
![]() ![]() | CreateCustomMeshMapping |
Create custom mesh mapping
|
![]() ![]() | CreateCylinderMapping | Create a cylindrical projection texture mapping. |
![]() ![]() | CreateOcsMapping |
Create a Ocs texture mapping. Note that OCS mappings must be placed on mapping channel ON_ObjectRenderingAttributes::OCSMappingChannelId()
otherwise they will not work.
|
![]() ![]() | CreatePlaneMapping(Plane, Interval, Interval, Interval) | Create a planar UV projection texture mapping |
![]() ![]() | CreatePlaneMapping(Plane, Interval, Interval, Interval, Boolean) | Create a planar projection texture mapping |
![]() ![]() | CreateSphereMapping |
Create a spherical projection texture mapping.
|
![]() ![]() | CreateSurfaceParameterMapping | Create a mapping that will convert surface parameters into normalized(0,1)x(0,1) texture coordinates. |
![]() | DataCRC |
Increments the Cyclic Redundancy Check value by this instance.
(Inherited from ModelComponent.) |
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) |
![]() | EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Evaluate(Point3d, Vector3d, Point3d) |
Evaluate the mapping to get a texture coordinate
|
![]() | Evaluate(Point3d, Vector3d, Point3d, Transform, Transform) |
Evaluate the mapping to get a texture coordinate
|
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) |
![]() | LockId |
Locks the component Id property.
(Inherited from ModelComponent.) |
![]() | LockIndex |
Locks the component Index property.
(Inherited from ModelComponent.) |
![]() | LockName |
Locks the component Name property.
(Inherited from ModelComponent.) |
![]() | ToJSON |
Create a JSON string representation of this object
(Inherited from CommonObject.) |
![]() | ToString |
Returns the name of the model component type, and then its name and index.
(Inherited from ModelComponent.) |
![]() | TryGetMappingBox(Plane, Interval, Interval, Interval) |
Get a box projection from the texture mapping.
|
![]() | TryGetMappingBox(Plane, Interval, Interval, Interval, Boolean) |
Get a box projection from the texture mapping, including capped information
|
![]() | TryGetMappingCylinder(Cylinder) |
Get a cylindrical projection parameters from this texture mapping.
|
![]() | TryGetMappingCylinder(Cylinder, Boolean) |
Get a cylindrical projection parameters from this texture mapping.
|
![]() | TryGetMappingMesh |
Get custom mapping mesh from this texture mapping.
|
![]() | TryGetMappingPlane(Plane, Interval, Interval, Interval) |
Get plane mapping parameters from this texture mapping.
|
![]() | TryGetMappingPlane(Plane, Interval, Interval, Interval, Boolean) |
Get plane mapping parameters from this texture mapping, including capping information
|
![]() | TryGetMappingSphere |
Get a spherical projection parameters from this texture mapping.
|