Click or drag to resize

TextureMappingCreateSphereMapping Method

Create a spherical projection texture mapping.

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static TextureMapping CreateSphereMapping(
	Sphere sphere
)

Parameters

sphere
Type: Rhino.GeometrySphere
sphere in world space used to define a spherical coordinate system. The longitude parameter maps (0,2pi) to texture "u" (0,1). The latitude parameter maps (-pi/2,+pi/2) to texture "v" (0,1). The radial parameter maps (0,r) to texture "w" (0,1).

Return Value

Type: TextureMapping
TextureMapping instance if input is valid
See Also