TextureMapping Methods |
The TextureMapping type exposes the following members.
Name | Description | |
---|---|---|
![]() | ClearId |
Resets the HasId property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearIndex |
Resets the HasIndex property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearName |
Resets the HasName property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() ![]() | CreateBoxMapping | Create a box projection texture mapping. |
![]() ![]() | CreateCustomMeshMapping |
Create custom mesh mapping
|
![]() ![]() | CreateCylinderMapping | Create a cylindrical projection texture mapping. |
![]() ![]() | CreateOcsMapping |
Create a Ocs texture mapping. Note that OCS mappings must be placed on mapping channel ON_ObjectRenderingAttributes::OCSMappingChannelId()
otherwise they will not work.
|
![]() ![]() | CreatePlaneMapping(Plane, Interval, Interval, Interval) | Create a planar UV projection texture mapping |
![]() ![]() | CreatePlaneMapping(Plane, Interval, Interval, Interval, Boolean) | Create a planar projection texture mapping |
![]() ![]() | CreateSphereMapping |
Create a spherical projection texture mapping.
|
![]() ![]() | CreateSurfaceParameterMapping | Create a mapping that will convert surface parameters into normalized(0,1)x(0,1) texture coordinates. |
![]() | DataCRC |
Increments the Cyclic Redundancy Check value by this instance.
(Inherited from ModelComponent.) |
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) |
![]() | EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Evaluate(Point3d, Vector3d, Point3d) |
Evaluate the mapping to get a texture coordinate
|
![]() | Evaluate(Point3d, Vector3d, Point3d, Transform, Transform) |
Evaluate the mapping to get a texture coordinate
|
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) |
![]() | LockId |
Locks the component Id property.
(Inherited from ModelComponent.) |
![]() | LockIndex |
Locks the component Index property.
(Inherited from ModelComponent.) |
![]() | LockName |
Locks the component Name property.
(Inherited from ModelComponent.) |
![]() | ToJSON |
Create a JSON string representation of this object
(Inherited from CommonObject.) |
![]() | ToString |
Returns the name of the model component type, and then its name and index.
(Inherited from ModelComponent.) |
![]() | TryGetMappingBox(Plane, Interval, Interval, Interval) |
Get a box projection from the texture mapping.
|
![]() | TryGetMappingBox(Plane, Interval, Interval, Interval, Boolean) |
Get a box projection from the texture mapping, including capped information
|
![]() | TryGetMappingCylinder(Cylinder) |
Get a cylindrical projection parameters from this texture mapping.
|
![]() | TryGetMappingCylinder(Cylinder, Boolean) |
Get a cylindrical projection parameters from this texture mapping.
|
![]() | TryGetMappingMesh |
Get custom mapping mesh from this texture mapping.
|
![]() | TryGetMappingPlane(Plane, Interval, Interval, Interval) |
Get plane mapping parameters from this texture mapping.
|
![]() | TryGetMappingPlane(Plane, Interval, Interval, Interval, Boolean) |
Get plane mapping parameters from this texture mapping, including capping information
|
![]() | TryGetMappingSphere |
Get a spherical projection parameters from this texture mapping.
|