Click or drag to resize

TextureMappingCreatePlaneMapping Method (Plane, Interval, Interval, Interval)

Create a planar UV projection texture mapping

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static TextureMapping CreatePlaneMapping(
	Plane plane,
	Interval dx,
	Interval dy,
	Interval dz
)

Parameters

plane
Type: Rhino.GeometryPlane
A plane to use for mapping.
dx
Type: Rhino.GeometryInterval
portion of the plane's x axis that is mapped to [0,1] (can be a decreasing interval)
dy
Type: Rhino.GeometryInterval
portion of the plane's y axis that is mapped to [0,1] (can be a decreasing interval)
dz
Type: Rhino.GeometryInterval
portion of the plane's z axis that is mapped to [0,1] (can be a decreasing interval)

Return Value

Type: TextureMapping
TextureMapping instance if input is valid
See Also