Click or drag to resize

SectionStyle Class

SectionStyle helps define the attributes to use when drawing a section
Inheritance Hierarchy

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public sealed class SectionStyle : ModelComponent

The SectionStyle type exposes the following members.

Constructors
  NameDescription
Public methodSectionStyle
Create a new instance of a SectionStyle
Public methodSectionStyle(SectionStyle)
Create a new SetionStyle that is a copy of another SectionStyle
Top
Properties
  NameDescription
Public propertyBackgroundFillColor
Fill color to apply to the background. Default is Color.Empty which means get the color from the source where this section style came from (object attributes or layer)
Public propertyBackgroundFillMode
How the background should be filled
Public propertyBackgroundFillPrintColor
Fill print color to apply to the background. Default is Color.Empty which means get the color from the source where this section style came from (object attributes or layer)
Public propertyBoundaryColor
Color to apply for the boundary curves. Default is Color.Empty which means get the color from the source where this section style came from (object attributes or layer)
Public propertyBoundaryPrintColor
Print color to apply for the boundary curves. Default is Color.Empty which means get the color from the source where this section style came from (object attributes or layer)
Public propertyBoundaryVisible
Should the boundary for this section be displayed
Public propertyBoundaryWidthScale
Scale applied to the boundary wire thickness
Public propertyComponentType
Returns SectionStyle.
(Overrides ModelComponentComponentType.)
Public propertyHatchIndex
Hatch pattern to use when drawing a fill pattern
Public propertyHatchPatternColor
Color to apply for the hatch pattern. Default is Color.Empty which means get the color from the source where this section style came from (object attributes or layer)
Public propertyHatchPatternPrintColor
Print color to apply for the hatch pattern. Default is Color.Empty which means get the color from the source where this section style came from (object attributes or layer)
Public propertyHatchRotationRadians
Rotation to apply to the hatch patterh
Public propertyHatchScale
Scale to apply to the hatch pattern
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertySectionFillRule
Rule to determine when to generate a hatch pattern and fill
Top
Methods
  NameDescription
Public methodGetBoundaryLinetype
Get an optional custom linetype associated with this section style. If null, then the linetype will come from the parent attributes or layer
Public methodRemoveBoundaryLinetype
Public methodSetBoundaryLinetype
Top
See Also