SectionStyle Properties |
The SectionStyle type exposes the following members.
Name | Description | |
---|---|---|
BackgroundFillColor |
Fill color to apply to the background. Default is Color.Empty which means
get the color from the source where this section style came from (object
attributes or layer)
| |
BackgroundFillMode |
How the background should be filled
| |
BackgroundFillPrintColor |
Fill print color to apply to the background. Default is Color.Empty which
means get the color from the source where this section style came from
(object attributes or layer)
| |
BoundaryColor |
Color to apply for the boundary curves. Default is Color.Empty which means
get the color from the source where this section style came from (object
attributes or layer)
| |
BoundaryPrintColor |
Print color to apply for the boundary curves. Default is Color.Empty which
means get the color from the source where this section style came from
(object attributes or layer)
| |
BoundaryVisible |
Should the boundary for this section be displayed
| |
BoundaryWidthScale |
Scale applied to the boundary wire thickness
ComponentType |
Returns SectionStyle.
Disposed |
Indicates if this object has been disposed or the
HatchIndex |
Hatch pattern to use when drawing a fill pattern
| |
HatchPatternColor |
Color to apply for the hatch pattern. Default is Color.Empty which means
get the color from the source where this section style came from (object
attributes or layer)
| |
HatchPatternPrintColor |
Print color to apply for the hatch pattern. Default is Color.Empty which
means get the color from the source where this section style came from
(object attributes or layer)
| |
HatchRotationRadians |
Rotation to apply to the hatch patterh
| |
HatchScale |
Scale to apply to the hatch pattern
InstanceDefinitionModelSerialNumber |
When a component is in a model as part of the information required for a linked instance definition,
IsDeleted |
true if the component is deleted.
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
IsReference |
Gets a value indicting whether this component is a referenced component.
| |
SectionFillRule |
Rule to determine when to generate a hatch pattern and fill
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user