Click or drag to resize

File3dmRenderContent Class

[Missing <summary> documentation for "T:Rhino.FileIO.File3dmRenderContent"]

Inheritance Hierarchy

Namespace:  Rhino.FileIO
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class File3dmRenderContent : ModelComponent

The File3dmRenderContent type exposes the following members.

Properties
  NameDescription
Public propertyAutoDelete
True if the content is automatically deleted when not in use.
Public propertyChildren
Public propertyChildSlotName
The render content's child slot name.
Public propertyComponentType
Returns RenderContent.
(Overrides ModelComponentComponentType.)
Public propertyFile3dmParent
The parent File3dm of the entire hierarchy.
Public propertyGroupId
The content's group id.
Public propertyHidden
True if the content is hidden.
Public propertyIsChild
True if this is a child of another render content (i.e., has a parent; is not top-level).
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyIsTopLevel
True if this is a top-level render content (i.e., has no parent; is not a child).
Public propertyKind
the kind of render content as a string.
Public propertyNotes
The content's notes.
Public propertyParent
The parent content or null if this is the top level object.
Public propertyPlugInId
The content's plug-in id.
Public propertyReference
True if the content is a reference content.
Public propertyRenderEngineId
The content's render-engine id.
Public propertyTags
The content's tags.
Public propertyTopLevel
The top-level parent content. Returns this if this is the top-level item.
Public propertyTypeId
The unique id of the content type.
Public propertyTypeName
The internal name of the content type.
Top
Methods
  NameDescription
Public methodChildSlotOn
True if a particular child slot is 'on'.
Public methodDeleteChild
Deletes any existing child with the specified child slot name. True if successful, else false.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodFindChild
The child with the specified child slot name, or null if no such child exists.
Public methodGetParameter
Gets a named parameter. The parameter value or null if not found.
Public methodSetParameter
Sets a named parameter. True if the parameter was set, else false.
Public methodXML
Gets the render content's state as an XML string.
Top
See Also