Click or drag to resize

Layer Class

[Missing <summary> documentation for "T:Rhino.DocObjects.Layer"]

Inheritance Hierarchy

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public sealed class Layer : ModelComponent, 
	IEquatable<Layer>

The Layer type exposes the following members.

Constructors
  NameDescription
Public methodLayer
Initializes a new instance of the Layer class
Top
Properties
  NameDescription
Public propertyColor
Gets or sets the display color for this layer.
Public propertyComponentStatus
Gets or sets the status of the layer.
(Overrides ModelComponentComponentStatus.)
Public propertyComponentType
Returns Layer.
(Overrides ModelComponentComponentType.)
Public propertyCode exampleFullPath
Gets the full path to this layer. The full path includes nesting information.
Public propertyId
Gets or sets the ID of this layer object. You typically do not need to assign a custom ID.
(Overrides ModelComponentId.)
Public propertyIgesLevel
Gets or sets the IGES level for this layer.
Public propertyIsCurrent
Returns true if the layer is the current layer.
Public propertyIsDeleted
Gets a value indicating whether this layer has been deleted and is currently in the Undo buffer.
(Overrides ModelComponentIsDeleted.)
Public propertyIsExpanded
Gets or sets a value indicating whether this layer is expanded in the Rhino Layer dialog.
Public propertyCode exampleIsLocked
Gets or sets a value indicating the locked state of this layer.
Public propertyIsReference
Gets a value indicting whether this layer is a referenced layer. Referenced layers are part of referenced documents.
(Overrides ModelComponentIsReference.)
Public propertyIsReferenceParentLayer
Returns true if the layer is a parent layer of the layer tree from a linked instance definition or the layer tree from a worksession reference model.
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyIsVisible
Gets or sets the global visibility of this layer.
Public propertyIsVisibleInUserInterface
Return true if the layer is visible in user interfaces that display layers. Returns false if the layer not visible in user interfaces. This is a runtime property that does not persist in .3dm files. This property is also used by the Layers panel to filter layers.
Public propertyLinetypeIndex
Gets or sets the line-type index for this layer.
Public propertyModelIsVisible
Gets or sets the model visiblity of this layer.
Public propertyModelPersistentVisibility
Gets or sets the model persistent visibility of this layer. The persistent viability setting is used for layers whose visibility can be changed by a parent layer. In this case, when a parent layer is turned off, then child layers are also turned off. The persistent visibility setting determines what happens when the parent is turned on again.
Public propertyCode exampleName
Gets or sets the name of this layer.
(Overrides ModelComponentName.)
Public propertyCode exampleParentLayerId
Gets the ID of the parent layer. Layers can be organized in a hierarchical structure, in which case this returns the parent layer ID. If the layer has no parent, Guid.Empty will be returned.
Public propertyPersistentVisibility
Gets or sets the global persistent visibility setting for this layer.
Public propertyPerViewportIsVisibleInNewDetails
Gets and sets the initial per viewport visibility of this layer in newly created detail views.
Public propertyPlotColor
Gets or sets the plot color for this layer.
Public propertyPlotWeight
Gets or sets the weight of the plotting pen in millimeters. A weight of 0.0 indicates the "default" pen weight should be used. A weight of -1.0 indicates the layer should not be printed.
Public propertyRenderMaterial
Gets or sets the RenderMaterial for objects on this layer that have MaterialSource() == MaterialFromLayer. A null result indicates that no RenderMaterial has been assigned and the material created by the default Material constructor or the RenderMaterialIndex should be used.
Public propertyRenderMaterialIndex
Gets or sets the index of render material for objects on this layer that have MaterialSource() == MaterialFromLayer. A material index of -1 indicates no material has been assigned and the material created by the default Material constructor should be used.
Public propertySortIndex
Runtime index used to sort layers in layer dialog.
Public propertyUserStringCount
Gets the amount of user strings.
Top
Methods
  NameDescription
Public methodCopyAttributesFrom
Copy typical attributes from another layer
Public methodDefault
Sets layer to default settings.
Public methodDeleteAllUserStrings
Public methodDeleteModelVisible
Remove any model visibility setting so the layer's global setting will be used for all viewports.
Public methodDeletePerViewportColor
Remove any per viewport layer color setting so the layer's overall setting will be used for all viewports.
Public methodDeletePerViewportPlotColor
Remove any per viewport layer plot color setting so the layer's overall setting will be used for all viewports.
Public methodDeletePerViewportPlotWeight
Remove any per viewport layer plot weight setting so the layer's overall setting will be used for all viewports.
Public methodDeletePerViewportSettings
Deletes per viewport layer settings.
Public methodDeletePerViewportVisible
Remove any per viewport visibility setting so the layer's overall setting will be used for all viewports.
Public methodDeleteUserString
Public methodEquals(Layer)
Public methodEquals(Object) (Overrides ObjectEquals(Object).)
Public methodGetChildren
Gets immediate children of this layer. Note that child layers may have their own children.
Public methodGetChildren(Boolean)
Gets the children of this layer.
Public methodGetCustomSectionStyle
Get an optional custom section style associated with these attributes.
Public methodStatic memberGetDefaultLayerProperties
Constructs a layer with the current default properties. The default layer properties are:

color = Rhino.ApplicationSettings.AppearanceSettings.DefaultLayerColor

line style = Rhino.ApplicationSettings.AppearanceSettings.DefaultLayerLineStyle

material index = -1

IGES level = -1

mode = NormalLayer

name = empty

layer index = 0 (ignored by AddLayer)

Public methodGetHashCode (Overrides ObjectGetHashCode.)
Public methodStatic memberGetLeafName(Layer)
Get a layer name's "leaf" level name
Public methodStatic memberGetLeafName(String)
Get a layer name's "leaf" level name
Public methodStatic memberGetParentName(Layer)
Get a layer's "parent" path name
Public methodStatic memberGetParentName(String)
Get a layer's "parent" path name
Public methodGetPersistentLocking
The persistent locking setting is used for layers that can be locked by a "parent" object. A common case is when a layer is a child layer (Layer.ParentI is not nil). In this case, when a parent layer is locked, then child layers are also locked. The persistent locking setting determines what happens when the parent is unlocked again.
Public methodGetPersistentVisibility
The global persistent visibility setting is used for layers whose visibility can be changed by a "parent" object. A common case is when a layer is a child layer (ParentId is not nil). In this case, when a parent layer is turned off, then child layers are also turned off. The persistent visibility setting determines what happens when the parent is turned on again.
Public methodGetUserString
Gets user string from this geometry.
Public methodGetUserStrings
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
Public methodHasPerViewportSettings
Verifies that a layer has per viewport settings.
Public methodHasSelectedObjects
Returns true if the layer has one or more selected Rhino objects.
Public methodIsChildOf(Guid)
Public methodIsChildOf(Int32)
Public methodIsChildOf(Layer)
Public methodIsParentOf(Guid)
Public methodIsParentOf(Int32)
Public methodIsParentOf(Layer)
Public methodParentLayer
Returns parent of a layer.
Public methodPerViewportColor
Gets the display color for this layer.
Public methodPerViewportIsVisible
Gets the per viewport visibility of this layer.
Public methodPerViewportPersistentVisibility
Gets the per layer persistent visibility. The persistent viability setting is used for layers whose visibility can be changed by a parent layer. In this case, when a parent layer is turned off, then child layers are also turned off. The persistent visibility setting determines what happens when the parent is turned on again.
Public methodPerViewportPlotColor
Gets the plot color for this layer.
Public methodPerViewportPlotWeight
Gets the plot weight, in millimeters, for this layer.
Public methodRemoveCustomSectionStyle
Public methodSetCustomSectionStyle
Public methodSetPersistentLocking
Set the persistent locking setting for this layer
Public methodSetPersistentVisibility
Set the global persistent visibility setting for this layer.
Public methodSetPerViewportColor
Sets the display color for this layer.
Public methodSetPerViewportPersistentVisibility
Sets the per layer persistent visibility. The persistent viability setting is used for layers whose visibility can be changed by a parent layer. In this case, when a parent layer is turned off, then child layers are also turned off. The persistent visibility setting determines what happens when the parent is turned on again.
Public methodSetPerViewportPlotColor
Sets the plot color for this layer.
Public methodSetPerViewportPlotWeight
Sets the plot weight, in millimeters, for this layer.
Public methodSetPerViewportVisible
Controls layer visibility in specific viewports.
Public methodSetUserString
Attach a user string (key,value combination) to this geometry.
Public methodToString (Overrides ModelComponentToString.)
Public methodUnsetModelPersistentVisibility
Remove any model persistent visibility setting from this layer.
Public methodUnsetPersistentLocking
Remove any explicitly persistent locking settings from this layer
Public methodUnsetPersistentVisibility
Remove any explicit persistent visibility setting from this layer
Public methodUnsetPerViewportPersistentVisibility
Remove any per viewport persistent visibility setting so the layer's overall setting will be used for all viewports.
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Public operatorStatic memberInequality
Top
See Also