Click or drag to resize

Layer Properties

The Layer type exposes the following members.

Properties
  NameDescription
Public propertyColor
Gets or sets the display color for this layer.
Public propertyComponentStatus
Gets or sets the status of the layer.
(Overrides ModelComponentComponentStatus.)
Public propertyComponentType
Returns Layer.
(Overrides ModelComponentComponentType.)
Public propertyCode exampleFullPath
Gets the full path to this layer. The full path includes nesting information.
Public propertyId
Gets or sets the ID of this layer object. You typically do not need to assign a custom ID.
(Overrides ModelComponentId.)
Public propertyIgesLevel
Gets or sets the IGES level for this layer.
Public propertyIsCurrent
Returns true if the layer is the current layer.
Public propertyIsDeleted
Gets a value indicating whether this layer has been deleted and is currently in the Undo buffer.
(Overrides ModelComponentIsDeleted.)
Public propertyIsExpanded
Gets or sets a value indicating whether this layer is expanded in the Rhino Layer dialog.
Public propertyCode exampleIsLocked
Gets or sets a value indicating the locked state of this layer.
Public propertyIsReference
Gets a value indicting whether this layer is a referenced layer. Referenced layers are part of referenced documents.
(Overrides ModelComponentIsReference.)
Public propertyIsReferenceParentLayer
Returns true if the layer is a parent layer of the layer tree from a linked instance definition or the layer tree from a worksession reference model.
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyIsVisible
Gets or sets the global visibility of this layer.
Public propertyIsVisibleInUserInterface
Return true if the layer is visible in user interfaces that display layers. Returns false if the layer not visible in user interfaces. This is a runtime property that does not persist in .3dm files. This property is also used by the Layers panel to filter layers.
Public propertyLinetypeIndex
Gets or sets the line-type index for this layer.
Public propertyModelIsVisible
Gets or sets the model visiblity of this layer.
Public propertyModelPersistentVisibility
Gets or sets the model persistent visibility of this layer. The persistent viability setting is used for layers whose visibility can be changed by a parent layer. In this case, when a parent layer is turned off, then child layers are also turned off. The persistent visibility setting determines what happens when the parent is turned on again.
Public propertyCode exampleName
Gets or sets the name of this layer.
(Overrides ModelComponentName.)
Public propertyCode exampleParentLayerId
Gets the ID of the parent layer. Layers can be organized in a hierarchical structure, in which case this returns the parent layer ID. If the layer has no parent, Guid.Empty will be returned.
Public propertyPersistentVisibility
Gets or sets the global persistent visibility setting for this layer.
Public propertyPerViewportIsVisibleInNewDetails
Gets and sets the initial per viewport visibility of this layer in newly created detail views.
Public propertyPlotColor
Gets or sets the plot color for this layer.
Public propertyPlotWeight
Gets or sets the weight of the plotting pen in millimeters. A weight of 0.0 indicates the "default" pen weight should be used. A weight of -1.0 indicates the layer should not be printed.
Public propertyRenderMaterial
Gets or sets the RenderMaterial for objects on this layer that have MaterialSource() == MaterialFromLayer. A null result indicates that no RenderMaterial has been assigned and the material created by the default Material constructor or the RenderMaterialIndex should be used.
Public propertyRenderMaterialIndex
Gets or sets the index of render material for objects on this layer that have MaterialSource() == MaterialFromLayer. A material index of -1 indicates no material has been assigned and the material created by the default Material constructor should be used.
Public propertySortIndex
Runtime index used to sort layers in layer dialog.
Public propertyUserStringCount
Gets the amount of user strings.
Top
See Also