Click or drag to resize

LayerGetDefaultLayerProperties Method

Constructs a layer with the current default properties. The default layer properties are:

color = Rhino.ApplicationSettings.AppearanceSettings.DefaultLayerColor

line style = Rhino.ApplicationSettings.AppearanceSettings.DefaultLayerLineStyle

material index = -1

IGES level = -1

mode = NormalLayer

name = empty

layer index = 0 (ignored by AddLayer)

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static Layer GetDefaultLayerProperties()

Return Value

Type: Layer
A new layer instance.
See Also