Click or drag to resize

Linetype Class

[Missing <summary> documentation for "T:Rhino.DocObjects.Linetype"]

Inheritance Hierarchy

Namespace:  Rhino.DocObjects
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public sealed class Linetype : ModelComponent

The Linetype type exposes the following members.

Constructors
  NameDescription
Public methodLinetype
Initializes a new instance of the Linetype class
Public methodLinetype(Linetype)
Initializes a new instance of the Linetype class
Top
Properties
  NameDescription
Public propertyAlwaysModelDistances
Linetype patterns and widths are typically interpreted as distances on the printed output when printing. In this case AlwaysModelDistances is false (default). When set to true, the linetype pattern and width will be interpreted as being in world distances. This is useful for cases like modeling a road as a single curve.
Public propertyComponentType
Returns LinePattern.
(Overrides ModelComponentComponentType.)
Public propertyInUse
Returns true if the linetype is in use by a Rhino object, a layer, an instance definition, or a section style.
Public propertyIsDeleted
Gets a value indicating whether this linetype has been deleted and is currently in the Undo buffer.
(Overrides ModelComponentIsDeleted.)
Public propertyIsModified
true if this linetype has been modified by LinetypeTable.ModifyLinetype() and the modifications can be undone.
Public propertyIsPatternLocked
Returns true if the pattern is locked and cannot be modified.
Public propertyIsReference
Gets a value indicting whether this linetype is a referenced linetype. Referenced linetypes are part of referenced documents.
(Overrides ModelComponentIsReference.)
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyLineCapStyle
Defines how the ends of open curves should be drawn
Public propertyLineJoinStyle
Defines how the corners of curves should be drawn
Public propertyName
The name of this linetype.
(Overrides ModelComponentName.)
Public propertyPatternLength
Total length of one repeat of the pattern.
Public propertySegmentCount
Number of segments in the pattern.
Public propertyUserStringCount
Gets the amount of user strings.
Public propertyWidth
Base width for this linetype
Public propertyWidthUnits
Unit system that widths are defined in. UnitSystem.None is default and means that the width is defined in pixels.
Top
Methods
  NameDescription
Public methodAppendSegment
Adds a segment to the pattern.
Public methodCommitChanges
Public methodStatic memberCreateFromPatternString
Creates a linetype from a pattern string. Values greater than zero represent line segments, and values less than or equal to zero represents space segments.
Public methodDefault
Set linetype to default settings.
Public methodDeleteAllUserStrings
Public methodDeleteUserString
Public methodDuplicateLinetype
Duplicates a linetype, clears the name, id, and locked bits.
Public methodGetSegment
Gets the segment information at a index.
Public methodGetTaperPoints
Taper points are positions/width combinations along the length of a curve
Public methodGetUserString
Gets user string from this geometry.
Public methodGetUserStrings
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
Public methodPatternString
Returns a string that represents the pattern of the linetype, which can be used in user interface. Values greater than zero represent line segments, and values less than or equal to zero represent space segments.
Public methodStatic memberReadFromFile
Reads linetypes from either a Rhino .3dm file or an AutoCAD .lin file.
Public methodRemoveSegment
Removes a segment in the linetype.
Public methodRemoveTaper
Remove taper information for stroke
Public methodSetSegment
Sets the length and type of the segment at index.
Public methodSetSegments
Set all segments.
Public methodSetTaper(Double, Double)
Set taper to a simple start width / end width
Public methodSetTaper(Double, Point2d, Double)
Set taper for this linetype width a single internal taper point
Public methodSetUserString
Attach a user string (key,value combination) to this geometry.
Top
See Also