CachedTextureCoordinates Class |
Namespace: Rhino.Render
The CachedTextureCoordinates type exposes the following members.
Name | Description | |
---|---|---|
Count |
Number of cached coordinates.
| |
Dim |
Coordinate dimension: 2 = UV, 3 = UVW
| |
Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) | |
HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) | |
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from CommonObject.) | |
IsReadOnly |
This collection is always read-only
| |
IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) | |
Item |
Gets the element at the specified index. Never call the set method, it
will always throw a NotSupportedException because this list is
read-only.
| |
MappingId |
The texture mapping Id.
| |
UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) | |
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use shareable set of information.
(Inherited from CommonObject.) |
Name | Description | |
---|---|---|
ConstructConstObject |
Assigns a parent object and a sub-object index to this.
(Inherited from CommonObject.) | |
Contains |
Determines whether this collection contains a specific value.
| |
CopyTo |
Copies the elements of the this collection to an System.Array,
starting at a particular System.Array index.
| |
Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) | |
Dispose(Boolean) |
For derived class implementers.
(Inherited from CommonObject.)This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method. | |
EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Inherited from CommonObject.) | |
GetEnumerator |
Returns an enumerator that iterates through this collection.
| |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
IndexOf |
Determines the index of a specific point in this collection.
| |
IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
NonConstOperation |
For derived classes implementers.
(Inherited from CommonObject.)Defines the necessary implementation to free the instance from being constant. | |
OnSwitchToNonConst |
Is called when a non-constant operation first occurs.
(Inherited from CommonObject.) | |
ToJSON |
Create a JSON string representation of this object
(Inherited from CommonObject.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
TryGetAt |
Use this method to iterate the cached texture coordinate array.
|